Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
rememberfunktion will nicht
#1
hallo liebes support team
ich nutze das mybb 1.1.7 auf nem php 4.4.2

was ich möchte:
wenn ich im user cp aktiviere das ich nicht automatisch eingeloggt werden will, das diese auch genauso funktioniert
-> kein auto login!, das will ich Smile

was passiert:
das forum funktioniert ansich super, allerdings will die funktion, das ich mich automatisch wieder einloggen muss sobald der browser geschlossen ist, nicht funktionieren

durch meine version 1.1.7 ist auch der entsprechende bugfix drin, (es gab ja schonmal so ein problem -> https://www.mybb.de/forum/showthread.php?tid=2764), habe dies auch überprüft, stimmt soweit

wenn ich mich expliziet abmelde funktioniert es das ich beim nächsten starten (also nach neustart des browsers) mich wieder einloggen muss

wenn ich jedoch eingeloggt bleibe und den browser nur beende dann bin ich beim neustart des browsers wieder eingeloggt (sowohl firefox und iex)

irgendwie scheint es, das das verfallsdatum immer auf heute + 1jahr gestellt wird, sobald ich eingeloggt bin

die checkbox in der usercpn -> optionen ist deselektiert
die datenbank habe ich zustäzlich geprüft und bei mir expliziet auf "no" gestellt (wobei das laut code unnötig ist da nur auf "yes" geprüft wird, aber das forum stellt wohl selbst auf no)

hoffe auf einen guten tip

vielen dank
kama
#2
HI, kama!

Vielleicht liegt es auch an deinem Browser, dass der die Cookies löscht, sobald das Fenster zu ist!?

Liebe Grüße, GM!
Wer eine Wahrheit verbergen will, braucht sie nur offen auszusprechen - sie wird einem ja doch nicht geglaubt.
(Charles Talleyrand)
#3
hallo grauer-magier
daran liegts leider nicht
wäre ja praktisch wenn mein browser die cookies löschen würde, tut er aber nicht, daher bin ich ja eingeloggt obwohl ich das nicht will

gruss
kama
#4
guten tag nochmal

also ich habe eine lösung, sie ist zwar nicht die schönste, aber sie funktioniert entsprechend meinen vorstellungen

-> inc/functions.php
suche folgende zeile:
$expires = time() + (60*60*24*365); // Make the cookie expire in a years time

diese zeile ist dafür zuständig die wiedererkennung auf heute + 1 jahr zu setzen, leider wird damit auch die sid für 1jahr gültig was nicht mein wunsch ist
in meinem fall habe ich die zeile auskommentiert und durch
$expires = 0;
ersetzt
dadurch sind die cookies nur gültig, solange der browser geöffnet ist / sich nicht abgemeldet wird

mein wunsch / ziel wird hierdurch erfüllt, leider weiss ich noch nicht was mit langzeitschäden ist, werde ich mal im auge behalten


zusätzlich
glaube ich einen fehler im script gefunden zu haben
-> inc/functions.php
suche zeile:
if($mybb->user['rememberme'] == "no") {

wenn ich mir von dem object mybb ein var_dump ziehe gibt es keine variable im array user, sonder nur die variable
"remember" anstatt "rememberme"
habe ich mal erweitert um:
        if($mybb->user['rememberme'] == "no") {
            $expires = 0;
        }
// die abfrage auf "remember" eingebaut da das mybb->user objekt keine variable
// mit rememberme enthält, dafür die remember variable
// die alte variable aus sicherheitsgründen drin gelassen
        else if(isset($mybb->user['remember']) && $mybb->user['remember'] == "no") // wird im objekt wiedergegeben
        {
            $expires = 0;
        }

damit wird es leider auch nicht gelösst, also ein schlechter fixWink
weiss der teufel warum keine notice kommt, aber darum habe ich mich nicht so gekümmert da ich mit dem fix von oben mein problem erschlagen habe Big Grin

hoffe geholfen zu haben
wäre dennoch an der richtigen lösung des problems interessiert

vielen dank
kama
#5
Ist dir klar, dass deine Änderung die Funktion für alle Benutzer lahmlegt?

Zu deinem Fix kann ich nichts sagen. Ich habe jedenfalls noch kein Problem in dieser Richtung gehabt und meines Wissens auch noch niemand anders Smile
Tritt der Fehler in diesem Forum auch auf?

Vantage-Forum: http://vantage-forum.de/
#6
hallo
ja ich weiss das das für ALLE user ist, im meinem fall ist es expliziet so gewünscht, hatte auch im template die option rausgenommen, beim speichern und anlegen von usern das feld "remember" auf "no" gestellt usw...

dachte das es reicht, aber leider war dem nicht so Sad

hier in dem forum habe ich es noch nicht getestet, mach ich aber mal Smile
läuft hier 1.1.7 oder auch die 1.2 ?

gruss
kama
#7
Hier läuft MyBB 1.17.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
#8
rehi
im schnelltest mit dem firefox habe ich hier genau das gleiche
bei deselektierten menüpunkt wiedererkennen bin ich erfolgreich eingeloggt

dann haben wir zumindest die gleichen forensoftware
ich habe das problem bei mir an zwei foren gehabt, testumgebung und dann online (also zwei verschiedene systeme)

mfg
kama
#9
OK, ich könnte mir vorstellen, dass der Fehler daher kommt:

Du loggst dich mit aktiver "Erinnerungsfunktion" ein. Der Cookie wird gespeichert. Du loggst dich aus, loggst dich erneut ein, diesmal ohne die Erinnerungsfunktion. Es könnte sein, dass der Cookie noch nicht (richtig) gelöscht wurde. Versuch mal, dich auszuloggen, alle Cookies zu löschen, und dann nochmal ohne die Option einzuloggen.
Vantage-Forum: http://vantage-forum.de/
#10
Der Fehler ist bekannt und ist in MyBB 1.2 gefixt. Den Fix findest du hier: https://www.mybb.de/forum/showthread.php...26#pid4526

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.