Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.17 veröffentlicht (16.07.18)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
[NG] Kalender erzeugt Fehlermeldung bei PHP 5.4 - manuelle Abhilfe gesucht
#11
Hast du doch selbst geschrieben in Beitrag #3.

Vielleicht kann dir Stefan die Datei zur Verfügung stellen...

Ich habe PHP 5.4 bislang nicht mal auf meinem unstable Gentoo, vor ein paar Wochen gab es da noch schwere Probleme (segfaults), wobei ich nicht sagen kann ob es an PHP oder an Gentoo liegt. Solange man nicht spezielles hat das zwingend PHP 5.4 voraussetzt nimmt man halt das was funktioniert und fertig aus.

Alles andere ist (wenn man auftretende Probleme nicht beheben kann/will) eben sich selbst im Weg stehen.

Gerade mal wieder PHP 5.4 ausprobiert, diesmal klappt es, aber mit PHP 5.4.9 bekomme ich keine Fehlermeldung im Kalender. Dafür im Admin CP aber die ist leicht zu beheben ($page->style wird gesetzt bevor $page initialisiert ist - später dann aber nochmal, also wirft man $page->style= raus).
#12
Hallo,

der Bug kommt oft erst nach dem man mehrtägige termine Eingetragen hat. auch bei 5.4.9 !
Der Bugfix der weiter oben beschrieben wurde Funtioniert nicht in jeder PHP Version

Ich habe jetzt nur die Datei inc/functions_calendar.php gändert.
Zeile 453 -> 455
Code:
$event['weekday_start'] = $calendar['weekstart'];

$start_day = gmmktime(0, 0, 0, $event_date[1], $event_date[0], $event_date[2]);
zu:
Code:
$event['weekday_start'] = 0;
if (isset ($calendar['startofweek'])) {
    $event['weekday_start'] = $calendar['startofweek'];
}
$start_day = gmmktime(0, 0, 0, $event_date[1], $event_date[0], $event_date[2]);

Danach Funktioniert das Ding ohne Probleme

Gruß
Robert
#13
Danke hat super geholfen.Smile

Aber da mir PHP leider nicht so geläufig ist, ich aber dennoch sehr interessiert bin, würde ich gern wissen, was genau sich hinter diesem Code verbirgt.

Ein paar Sachen sind mir aber geläufig.Wink
#14
Das Problem wurde doch mit MyBB 1.6.10 behoben?
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.