Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.10 veröffentlicht (10.01.17)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Problem mit Design
#1
hallo, ich wollte beim OrangeIce-Design nen zusätzlichen Button einbauen .. dazu habe ich die header-Datei im Template entsprechend abgeändert.
Dabei habe ich wohl das Design leicht "zerschossen" .. ein Rückgängig-machen der Änderungen brachte leider nichts.
Kann mir jemand sagen woran es liegt, das der Schatten so wie im Anhang dargestellt wird ?

Gruß
Frank

   
Zitieren
#2
Poste bitte mal einen Link zur Seite.
Vantage-Forum: http://vantage-forum.de/
Zitieren
#3
http://www.doppelrocken.de
Zitieren
#4
mein header-template sieht so aus:

PHP-Code:
<script language="Javascript" type="text/javascript">
         var 
cookieDomain "$settings[cookiedomain]";
         var 
cookiePath "$settings[cookiepath]";
         var 
quickdelete_confirm "$lang->quickdelete_confirm";
         var 
newpm_prompt "$lang->newpm_prompt";
         var 
deleteevent_confirm "$lang->deleteevent_confirm";
         var 
removeattach_confirm "$lang->removeattach_confirm";
    </
script>
    <
div id="container">
        <
div id="header">
        <
div class="logo">
        <
table width="100%"  border="0" cellspacing="0" cellpadding="0">
  <
tr>
    <
td align="left" valign="top"><a href="$settings[bburl]/index.php" name="top"><img src="$theme[logo]alt="$settings[bbname]border="0" /></a></td>
    <
td align="right" valign="top"><a href="$settings[bburl]/search.php"><img src="$theme[imgdir]/toplinks/search.gif" alt="$lang->toplinks_searchtitle="$lang->toplinks_searchborder="0" style="margin:0px; padding:0px;" /></a>
    <
a href="$settings[bburl]/memberlist.php"><img src="$theme[imgdir]/toplinks/memberlist.gif" border="0" title="$lang->toplinks_memberlistalt="$lang->toplinks_memberliststyle="margin:0px; padding:0px;" /></a>
    <
a href="$settings[bburl]/calendar.php"><img src="$theme[imgdir]/toplinks/calendar.gif" border="0" title="$lang->toplinks_calendaralt="$lang->toplinks_calendarstyle="margin:0px; padding:0px;" /></a>
    <
a href="$settings[bburl]/misc.php?action=help"><img src="$theme[imgdir]/toplinks/help.gif" border="0" title="$lang->toplinks_helpalt="$lang->toplinks_helpstyle="margin:0px; padding:0px;" /></a></td>
  </
tr>
</
table>
        </
div>
            <
hr class="hidden" />
            <
div id="panel">
                
$welcomeblock
            
</div>
                              <
div class="schatten_panel"><img src="images/OrangeIce/schatten_links.gif" alt="" width="8" height="8" align="left" style="border:0px; padding:0px; margin:0px;" /><img src="images/OrangeIce/schatten_rechts.gif" alt="" width="8" height="8" align="right" style="border:0px; padding:0px; margin:0px;" />
            </
div>
        </
div>
        <
hr class="hidden" />
        <
br class="clear" />
        <
div id="content">
            
$bannedwarning
            $bbclosedwarning
            $unreadreports
            
<navigation>
            <
br class="clear" /> 

vielleicht hilft das ja weiter ... der Inhalt ist allerdings absolut identisch zu dem aus der xml-Datei zum Theme
Zitieren
#5
Also ich habe das Forum mal durch den Validator laufen lassen, es sind einige Codefehler drin. Das unmodifizierte MyBB hat keine, da stimmt also was nicht, guck dir das mal an:

http://validator.w3.org/check?uri=http%3...2Fforum%2F

Ich glaube der Fehler liegt darin, dass im Theme etwas geändert wurde. Am einfachsten ist es, wenn du das Theme nochmal neu hochlädst.
Vantage-Forum: http://vantage-forum.de/
Zitieren
#6
Hallo,

wo sollte der Schatten denn sonst sein oder ist dein Problem die weißte Überschneidung am Rand der Box?

Ich habe es mal so geändert wie es gut aussieht:
Im richtigen Template diesen Teil
Code:
<div class="schatten_panel"><img src="images/OrangeIce/schatten_links.gif" alt="" width="8" height="8" align="left" style="border:0px; padding:0px; margin:0px;" /><img src="images/OrangeIce/schatten_rechts.gif" alt="" width="8" height="8" align="right" style="border:0px; padding:0px; margin:0px;" />
</div>
durch diesen ersetzen:
Code:
<div class="schatten_panel"></div>
Jetzt sind die Bilder weg und man hat keine komischen Punkte mehr.

Beim CSS-Kram suchen nach:
Code:
.schatten_panel {
background-image:url(images/OrangeIce/schatten.gif);
background-repeat:repeat-x;
height:8px;
padding:0px;
margin:-16px 0px 0px 0px;
}

und ersetzen durch
Code:
.schatten_panel {
background-image:url(images/OrangeIce/schatten.gif);
background-repeat:repeat-x;
height:8px;
padding:0px;
margin:-29px 1px 0px 1px;
}

Mfg
Yast
Zitieren
#7
hat leider nicht funktioniert .. aber trotzdem danke.
Hab das Theme nochmal neu hochgeladen. Ich musste dafür zwar alles neu anpassen, aber es ging ja nicht anders.
Zur Sicherheit habe ich das Theme jetzt exportiert Smile
Zitieren
#8
Hat nicht funktioniert? Das wundert mich, bei mir hat es einwandfrei geklappt.

Mfg
Yast
Zitieren