Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.12 veröffentlicht (22.05.17)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Upgrade von 1.2.2 auf 1.6.7 - UTF-Konvertierung schneidet Posts ab / Umlaute
#1
Hallo Zusammen!

Ich habe heute ein Upgrade von 1.2.2 auf 1.6.7 gemacht. Das lief alles toll, bis ich die merkte das die Umlaute im Text falsch angezeigt werden. Ich habe dann gesehen, dass man die Datenbank auf UTF8 konvertieren kann und habe es versucht.

Die Umlaute waren dann korrekt, aber die Posts nach wenigen Zeichen abgeschnitten. Ist das ein bekanntes Problem? Was kann getan werden?

MfG, MR
#2
Wow das nenn ich aber mal ein Upgrade !! Toungue Von 1.2.2 auf 1.6.7 ? Warst Du auf irgenteiner Insel verschollen oder 1 Jahr im Urlaub ?
Mit freundlichen Grüßen

MrBrechreiz
#3
Das Problem hatte ich auch, lag damals an meinem Browser, schonmal mit einem anderen versucht ?

Gruss.
#4
(16.04.2012, 22:55)MrBrechreiz schrieb: Wow das nenn ich aber mal ein Upgrade !! Toungue Von 1.2.2 auf 1.6.7 ? Warst Du auf irgenteiner Insel verschollen oder 1 Jahr im Urlaub ?

Sowas in der Art... und "never change an running system" Smile)
#5
Wurden die Texte jeweils bei Umlauten abgebrochen? Wenn ja, das hatte ich auch mal und hier eine Lösung von frostschutz erhalten. Muss mich mal auf die Suche machen....
viele Grüße
Jockl
übersetzte und eigene Plugins
#6
(16.04.2012, 23:03)Jockl schrieb: Wurden die Texte jeweils bei Umlauten abgebrochen? Wenn ja, das hatte ich auch mal und hier eine Lösung von frostschutz erhalten. Muss mich mal auf die Suche machen....

Ich denke ja - ich habe gerade mit phpMyAdmin die eine oder andere Tabelle auf das Format umgestellt. Es scheint nun zu klappen. Aber es sind sehr viele Tabellen übrig
#7
Vielleicht hilft Dir dieser Beitrag (ff.) weiter. Hierzu benötigst Du aber Konsolen-Zugriff oder ein Linux System, das den Befel iconv kennt.
viele Grüße
Jockl
übersetzte und eigene Plugins
#8
Sprich etwas dagegen die Umstellung auf UTF8 "einfach" mit phpMyAdmin zu machen?

Ich denke es läuft nun alles: ich habe die Datenbanktabellen mit den Posts nicht über das Tool des Formuns auf UTF8 umstellen lassen, sondern es von Hand mit phpMyAdmin gemacht.

Die restlichen Tabellen enthalten ja im Grund kaum relavanten Text und diese haben ich dann mit dem Tool des Forums konvertieren lassen.
#9
Hallo zusammen,

auch ich war ein Jahr in Urlaub Wink und habe heute von 1.2.2 auf aktuell umgestellt. Hat alles geklappt, bis auf die Umlaute. Bei mir werden aber alle Sonderzeichen in einer schwarzen Raute mit Fragezeichen dargestellt. Z. B. so:

Durchf�hrung der Sprachtests f�r alle vierj�hrigen Kinder

In der Datenbank sind alle Tabellen (alle Zeilen aller Tabellen) auf latin1_swedish_ci eingestellt. Ich habe die entsprechende Tabelle für die post´s alle auf utf8_general_ci geändert, aber im Forum im Netz tut sich leider nichts. In der Datenbank sind alle Umlaute zu sehen, also ein Updatescript zur Umsetzung hilft hier nicht.

Bei der allgemeinen Einstellung der Datenbank ist Deutsch und utf8_general_ci angegeben.

Was kann ich tun. Ist es irgendwo in einer Konfig-Datei eine Einstellung?

Ich habe zwei verschiedene Browser (chrome und mozilla) auf zwei verschiedenen Systemen ausprobiert. An der Browserkonfig kann es auch nicht liegen. Immer gleich.

Für Tipps bin ich sehr dankbar!

Ach, und noch eine Info: Wir haben mehrere Datenbank bei uns laufen. In einer für Presseartikel sind auch alle Tabellenzeilen auf latin1_swedish_ci eingestellt und dort werden die Umlaute im Browser dargestellt. In einer anderen Datenbank sind aber alle Einstellungen auf utf8_general_ci. ?????
Gruß
Labusch
#10
Hast Du das hier schon probiert?
https://www.mybb.de/doku/sonstiges/utf-8-konvertierung/
viele Grüße
Jockl
übersetzte und eigene Plugins


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Konvertierung von Burning Board 4 nach MyBB aovb 2 579 03.01.2014, 15:37
Letzter Beitrag: Jockl
  Merge von phpBB auf MyBB - Umlaute in Usernamen patx 7 1.441 25.04.2013, 21:11
Letzter Beitrag: sns