Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.27 veröffentlicht (22.06.21)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
User Quickmenu In Postbit
#1
Eine neue Erweiterung wurde veröffentlicht: User Quickmenu In Postbit

Zitat:Compatibility: MyBB 1.4, MyBB 1.6

Languages: English

Features:
-Displays a quick user menu when you click on the author's name in postbit profile box with quick options to view profile, view threads, view posts, send pm, send email and add/remove buddy in default postbit and classic postbit layout.

[Bild: http://mods.mybb.com/uploads/previews/29....thumb.PNG]
[Bild: http://mods.mybb.com/uploads/previews/29....thumb.PNG]

Installation: Upload the files to the mybb root folder and go to ACP->Configuration->Plugins and activate "User Quickmenu In Postbit".
Zitieren
#2
Hi,

Ich habe mir das Plugin hier runtergeladen

Habe auch alles hoch geladen und aktiviert. Jedoch funktioniert das Plugin nicht wie es sein soll. Es öffnet sich kein Menu Bereich im Postbit...

Woran liegs?

Lg
Zitieren
#3
Ein Link wäre sehr hilfreich.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#4
Also ich habs überprüft und es funktioniert tatsächlich nicht, und ich nicht unbedingt ein Greenhorn Wink
Ich denke, daß das überschreiben der Templates nicht funktioniert.
Zitieren
#5
(24.12.2010, 11:23)Plexxart schrieb: Also ich habs überprüft und es funktioniert tatsächlich nicht, und ich nicht unbedingt ein Greenhorn Wink
Ich denke, daß das überschreiben der Templates nicht funktioniert.

Also ich habs jetzt hinbekommen; die Templates werden wohl überschrieben, aber nicht vollständig. Es fehlt schlicht und einfach die Java Script datei.
Um das Plugin zum laufen zu bringen muß man in der Gruppe Postbit Templates die Templates "postbit" und "postbit_classic" verändern.

In diesen jeweils am Ende nach </table> folgendes einfügen und dann das Template speichern:

Code:
<script type="text/javascript">
// <!--
    if(use_xmlhttprequest == "1")
    {
        new PopupMenu("profile_{$post['pid']}");
    }
// -->
</script>

Dieses Script ist auch im Plugin angeführt, aus welchen Gründen auch immer wird dieses ins Template nicht hineingeschrieben.

Die Stelle aus dem Plugin:

PHP-Code:
find_replace_templatesets("postbit_classic""#".preg_quote($old)."#i"$new);
        
        
$new '</tbody>
</table>
<script type="text/javascript">
// <!--
    if(use_xmlhttprequest == "1")
    {
        new PopupMenu("profile_{$post[\'pid\']}");
    }
// -->
</script>'
;
        
$old '</tbody>
</table>'
;
        
find_replace_templatesets("postbit""#".preg_quote($old)."#i"$new);
        
        
$new '</table>
    </td>
</tr>
</table>
<script type="text/javascript">
// <!--
    if(use_xmlhttprequest == "1")
    {
        new PopupMenu("profile_{$post[\'pid\']}");
    }
// -->
</script>'
;
        
$old '</table>
    </td>
</tr>
</table>'
;
        
find_replace_templatesets("postbit_classic""#".preg_quote($old)."#i"$new);


Vielleicht kann sich Stefan das mal anschauen und uns sagen was hierbei falsch ist, weil dann können wir das korrigieren und das korrigierte Plugin hier posten.

Frohe Weihnacht !
Zitieren
#6
Wäre echt nett...
Frohe Weihnachten euch allen! Smile
Zitieren
#7
Hallo

Also ich habe das Plugin jetzt nochmals überprüft und es scheint so, daß dieses nur funktioniert wenn man das Template "postbit" und "postbit_classic" nicht bearbeitet hat oder wurde.
Wobei es hierbei nur Probleme mit dem reinschreiben der Java Script datei gibt, alles andere wird korrekt ausgeführt.

Werden die beiden Templates aufs Original zurückgesetzt, so funktioniert das Aktivieren und Deaktivieren des Plugins problemlos.
Ich abe das Plugin auch mit einer deutschen Sprachdatei erweitert und das schaut jetzt im klasischen Modus so aus:

   

Vielleicht könnt uns da einer helfen, weil ich bin mit meinem Latein am Ende Sad
Zitieren
#8
Dieses Problem wird sich wohl nie gänzlich vermeiden lassen, wenn es um Änderungen an Templates geht, die nicht dem Original entsprechen. Vielleicht wäre ja auch dieses Plugin eine Alternative. Ist zwar für 1.4 aber bestimmt auch bei 1.6 anwendbar.
viele Grüße
Jockl
übersetzte und eigene Plugins
Zitieren
#9
Danke Jockl für den Link !
Nur das ist wieder etwas anderes. Mir gehts ja eigentlich darum, daß ich das Problem begreife.
Einerseits wird der Code vom Menü ins schon bearbeitete Template reingeschrieben aber der vom JS nicht und das verstehe ich eigentlich nicht.
Nur beim Originalen Template wird auch die JS hineingeschrieben.
Zitieren
#10
Das Problem ist, dass nur irgendwo (im Template oder in der Plugin-Datei) ein Blank falsch gesetzt sein muss, ein Tab oder Zeilenumbruch, wo keiner ist, und schon funktioniert das ganze nicht mehr....
viele Grüße
Jockl
übersetzte und eigene Plugins
Zitieren