Hallo, Gast! (Registrieren)

Letzte Ankündigung: Sicherheitsupdate: MyBB 1.8.32 veröffentlicht (19.11.22)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Banned Fun
#1
Eine neue Erweiterung wurde veröffentlicht: Banned Fun

Zitat:This mod inflicts 4 different torture types on the usergroup(s) you choose.


The tortures are
-Getting to the actual page they want, but only every once in a while
-100s and 100s of Popups
-Getting sent to a random page
-Timed Out

Basically, it will just mess with your members who have been bad. I am
using it for banned members, but it can be used on anyone. All settings
are changable, and each torture can be turned off...
Zitieren
#2
Hallo,


vielleicht kann mir jemand helfen?

Ich habe heute endlich mal die Gelegenheit, einen User mit dem Banned Fun zu belegen, aber im Test erhalte ich dazu folgende Fehlermeldungen (über dem header):

Zitat:Warning: Cannot modify header information - headers already sent by (output started at /www/htdocs/w00XXXXx/forum/inc/plugins/banned.php:226) in /www/htdocs/w00XXXXx/forum/inc/plugins/utf8_header.php on line 31

Warning: Cannot modify header information - headers already sent by (output started at /www/htdocs/w00XXXXx/forum/inc/plugins/banned.php:226) in /www/htdocs/w00XXXXx/forum/inc/functions.php on line 78

Wie kann ich diese Meldung verhindern? Nicht, daß der User gleich den Braten riecht, wenn er dabei das Wort "banned" liest.

Noch benutze ich die Version 1.2.9

Danke schon mal für Eure Hilfe.
Liebe Grüße
Dummuser (der seine verzweifelten Versuche, auf 1.4.4 usw. umzusteigen, nicht aufgegeben hat und vorerst mit der aktuellsten Version 1.4.4 (mit einigen Baustellen) doch nicht als Dummmumie in die MyBB-Annalen eingehen wird - DANKE an das ganze Team!
Zitieren
#3
Benutzt du die deutsche Version des Plugins? Dort kann ich den Fehler nicht nachvollziehen.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#4
Hi,

habe jetzt die deutsche Version geholt und installiert, aber der Fehler kommt jetzt auch:

Zitat:Warning: Cannot modify header information - headers already sent by (output started at /www/htdocs/w00XXXXxe/forum/inc/plugins/banned.php:225) in /www/htdocs/w00XXXXx/forum/inc/functions.php on line 78

in der functions.php in Zeile 78 steht:
Code:
header("Content-type: text/html; charset={$lang->settings['charset']}");


Wo hab ich einen Fehler?
Liebe Grüße
Dummuser (der seine verzweifelten Versuche, auf 1.4.4 usw. umzusteigen, nicht aufgegeben hat und vorerst mit der aktuellsten Version 1.4.4 (mit einigen Baustellen) doch nicht als Dummmumie in die MyBB-Annalen eingehen wird - DANKE an das ganze Team!
Zitieren
#5
Die Funktion mit dem Popup erzeugt wohl das Problem. Wenn du diesen Teil nicht brauchst lösche das:
PHP-Code:
elseif ($do == "popup")
        {
                echo (
"
                <script type='text/javascript'>
                var x=1;
                while (x<=
$howmanypopups)
                {
                alert('
$popupssay');
                x++
                }
                </script>
                "
);

[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren


Möglicherweise verwandte Themen…
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Redirect banned members MyBB.de Bot 0 862 11.12.2015, 14:05
Letzter Beitrag: MyBB.de Bot
  Ircher Fun MyCodes Extension MyBB.de Bot 0 871 13.03.2015, 22:40
Letzter Beitrag: MyBB.de Bot
  No Banned Profile MyBB.de Bot 0 1.040 21.03.2013, 05:55
Letzter Beitrag: MyBB.de Bot
  Banned to view threads MyBB.de Bot 1 1.370 04.12.2011, 10:07
Letzter Beitrag: MyBB.de Bot
  Profile Banned MyBB.de Bot 0 1.479 22.12.2010, 18:21
Letzter Beitrag: MyBB.de Bot