Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.14 veröffentlicht (30.11.17)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Editor wird nicht angezeigt
#1
Hey, ich bin gerade dabei mein Forum ein bisschen zu modifizieren.
Dabei ist jetzt folgendes Problem aufgetreten. Beim ersten Textare wird kein BB-Code-Editor angezeigt.
Der Code ist in einem Template, welches ich dank einem Plugins mit PHP versehren darf.

PHP-Code:
<?php if($_GET['op'] == "edit") {
echo 
'<tr id="comment_form">
    <td colspan="2" style="text-align: left;" class="trow2">
        <form id="newcomment" name="newcomment" action="member.php?action=profile&amp;uid='
.$this->target['uid'].'&amp;op=do_edit&amp;mid='.$comment['mid'].'" method="post">
            <div id="replyingto" class="pm_alert" style="display: none;"></div>
            <p>
                <textarea name="editmessage" id="editmessage" rows="10" cols="70" tabindex="3">'
.$comment['text'].'</textarea>
            </p>
            <p>
                <input type="hidden" name="reply_to_profile" id="reply_to_profile" value="default" />
                <input type="hidden" name="to_uid" id="to_uid" value="'
.$this->target['uid'].'}" />
                <input type="submit" value="'
.$lang->profile_comments_edit_button.'" tabindex="4" />

            </p>
            '
.build_mycode_inserter().'
        </form>
    </td>
</tr>'
;
} else {
echo 
'<tr id="comment_form">
    <td colspan="2" style="text-align: left;" class="trow2">
        <form id="newcomment" name="newcomment" action="member.php?action=profile&amp;uid='
.$this->target['uid'].'&amp;op=new" method="post">
            <div id="replyingto" class="pm_alert" style="display: none;"></div>
            <p>
                <textarea name="message" id="message" rows="10" cols="70" tabindex="5"></textarea>
            </p>
            <p>
                <input type="hidden" name="reply_to_profile" id="reply_to_profile" value="default" />
                <input type="hidden" name="to_uid" id="to_uid" value="'
.$this->target['uid'].'" />
                <input type="submit" id="sendcomment" value="'
.$lang->profile_comments_add_button.'" tabindex="6" />

            </p>
            '
.build_mycode_inserter().'
            <script type="text/javascript">
                var editorloaded = {$editor_active};
                var comments_ajax = {$ajax};
                var current_user = '
.$mybb->input['uid'].';
                var replying_message =   \'{$lang->profilecomments_replying}\';
                var confirm_delete_message = \'{$lang->profilecomments_confirm_delete}\';
            </script>
        </form>
    </td>
</tr>'
; }

 
?>

Lieben Dank im Voraus.

Gruß ♥
Zitieren
#2
Ferndiagnose bei vollkommen verändertem Code ist nicht einfach...
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#3
Der Fehler aber hat doch nichts mit dem verändertem Code zu tun..
Tatsache ist: Im Else-Part funktioniert die BB-Code-Leiste, im If-Part nicht - trotz der nur geringen Differenzen.

Gruß ♥
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Smiley-Link funktioniert nicht & Editor wird nicht angezeigt Steffi2012 3 1.521 15.10.2012, 20:50
Letzter Beitrag: Steffi2012
  Header ist nicht in der Mitte & Online Status wird nicht angezeigt Schoani 1 757 15.10.2011, 18:29
Letzter Beitrag: Megaleecher