Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Chat Umlaute Problem
#1
Hallo ,
ich habe vor 3 tagen ein mybb forum erstellt.
bisher lief alles echt super.
nur jetzt habe ich eine Chat/Shoutbox Intregiert
lief auch problemlos...
aber wenn man etwas mit umlauten schreibt kommen sachen wie: können , dürfen oder Ärger
ich benutze diese Software: http://community.mybb.com/thread-63559.h...e+shoutbox

währe es möglich die Umlaute richtig anzeigen zu lassen?

EDIT: Das betrifft auch "ß"
_____________________________________________________________________
oder kennt ihr ne Software mit ähnlich guten Features?


MFG NoNoZ
Zitieren
#2
(24.04.2011, 20:49)NoNoZ schrieb: währe es möglich die Umlaute richtig anzeigen zu lassen?

Hi,
das scheint ein gewöhnlicher utf-8 Fehler zu sein.
Hab den Quellcode mal eben überflogen, änder mal in der chatbox/functions.php die Zeile 191 von
PHP-Code:
    $text $shout['message']; 
in
PHP-Code:
    $text utf8_decode($shout['message']); 
und in Zeile 245
PHP-Code:
            $shout['message'] = formattext($shout['message'], $shout['bold'], $shout['italic'], $shout['underline'], $shout['font'], $shout['color']); 
in
PHP-Code:
            $shout['message'] = utf8_decode(formattext($shout['message'], $shout['bold'], $shout['italic'], $shout['underline'], $shout['font'], $shout['color'])); 
. Das könnte das Problem beheben (hab's aber nicht getestet Wink)

Grüße
Zitieren
#3
vielen dank, werde es gleich mal testen!
________________________________________________________________________

nun schreibt er statt umlaute fragezeichen.
könnte man das auch noch beheben ?
bsp. k?nnte


dank der vorabeit von sevildevil habe ich es endlich geschafft.
ich musste einfach die fcb_message.txt datei in UTF-8 codierung abspeichern...
naja Thread kann geschlossen werden Smile
Thread offen lassen habe rausgefunden das es nach ein post wieder weg ist...
ich glaube die text datei wird dann wieder als in eine andere codierung aktualisiert..
wie kann ich verhindern das die datei eine andere codierung bekommt als wie ich sie abspeichere ?
Zitieren
#4
Hi,

hatte mal ein ähnliches Problem. Ich konnte es beheben, indem ich

AddDefaultCharset utf-8

in die .htaccess eingefügt habe, vielleicht hilft es dir ja weiter?
Gruß
Marcel
[Bild: pcpedia_banner_332x60.png]
Zitieren
#5
die htacces datei ist bei mir ein problem...
bei mir existiert eine htacccess.txt
die habe ich mal als .htaccess abgespeichert, und auf einmal war meine ganze seite down!
(
Code:
Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmasterfunpic.de and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.
)
ich kann ja mal die htaccess datei hier posten.

PHP-Code:
Options -MultiViews +FollowSymlinks -Indexes

#
# If mod_security is enabled, attempt to disable it.
# - Note, this will work on the majority of hosts but on
#   MediaTemple, it is known to cause random Internal Server
#   errors. For MediaTemple, please remove the block below
#
<IfModule mod_security.c>
    
# Turn off mod_security filtering.
    
SecFilterEngine Off

    
# The below probably isn't needed, but better safe than sorry.
    
SecFilterScanPOST Off
</IfModule>

#
# MyBB "search engine friendly" URL rewrites
# - Note, for these to work with MyBB please make sure you have
#   the setting enabled in the Admin CP and you have this file
#   named .htaccess
#
<IfModule mod_rewrite.c>
    
RewriteEngine on
    RewriteRule 
^forum-([0-9]+)\.htmlforumdisplay.php?fid=$[L,QSA]
    
RewriteRule ^forum-([0-9]+)-page-([0-9]+)\.htmlforumdisplay.php?fid=$1&page=$[L,QSA]

    
RewriteRule ^thread-([0-9]+)\.htmlshowthread.php?tid=$[L,QSA]
    
RewriteRule ^thread-([0-9]+)-page-([0-9]+)\.htmlshowthread.php?tid=$1&page=$[L,QSA]
    
RewriteRule ^thread-([0-9]+)-lastpost\.htmlshowthread.php?tid=$1&action=lastpost [L,QSA]
    
RewriteRule ^thread-([0-9]+)-nextnewest\.htmlshowthread.php?tid=$1&action=nextnewest [L,QSA]
    
RewriteRule ^thread-([0-9]+)-nextoldest\.htmlshowthread.php?tid=$1&action=nextoldest [L,QSA]
    
RewriteRule ^thread-([0-9]+)-newpost\.htmlshowthread.php?tid=$1&action=newpost [L,QSA]
    
RewriteRule ^thread-([0-9]+)-post-([0-9]+)\.htmlshowthread.php?tid=$1&pid=$[L,QSA]

    
RewriteRule ^post-([0-9]+)\.htmlshowthread.php?pid=$[L,QSA]

    
RewriteRule ^announcement-([0-9]+)\.htmlannouncements.php?aid=$[L,QSA]

    
RewriteRule ^user-([0-9]+)\.htmlmember.php?action=profile&uid=$[L,QSA]

    
RewriteRule ^calendar-([0-9]+)\.htmlcalendar.php?calendar=$[L,QSA]
    
RewriteRule ^calendar-([0-9]+)-year-([0-9]+)\.htmlcalendar.php?action=yearview&calendar=$1&year=$[L,QSA]
    
RewriteRule ^calendar-([0-9]+)-year-([0-9]+)-month-([0-9]+)\.htmlcalendar.php?calendar=$1&year=$2&month=$[L,QSA]
    
RewriteRule ^calendar-([0-9]+)-year-([0-9]+)-month-([0-9]+)-day-([0-9]+)\.htmlcalendar.php?action=dayview&calendar=$1&year=$2&month=$3&day=$[L,QSA]
    
RewriteRule ^calendar-([0-9]+)-week-(n?[0-9]+)\.htmlcalendar.php?action=weekview&calendar=$1&week=$[L,QSA]

    
RewriteRule ^event-([0-9]+)\.htmlcalendar.php?action=event&eid=$[L,QSA]

    <
IfModule mod_env.c>
        
SetEnv SEO_SUPPORT 1
    
</IfModule>
</
IfModule>

#
# If Apache is compiled with built in mod_deflade/GZIP support
# then GZIP Javascript, CSS, HTML and XML so they're sent to
# the client faster.
#
<IfModule mod_deflate.c>
    
AddOutputFilterByType DEFLATE application/javascript text/css text/html text/xml
</IfModule
Zitieren
#6
Ja die htaccess.txt habe ich auch, die kannst du lassen. Mach einfach die andere zusätzlich, hat bei mir auch geklappt Smile
Gruß
Marcel
[Bild: pcpedia_banner_332x60.png]
Zitieren
#7
dh. ich soll einfach eine .htacces datei erstellen mit nur diesen code ?
____________________________________________________________
habe es gemacht und ohne erfolg Sad
Zitieren
#8
Schade bei mir hat das geholfen. Kann aber sein, dass dein Hoster das nicht unterstützt, frag am Besten mal nach!
Gruß
Marcel
[Bild: pcpedia_banner_332x60.png]
Zitieren
#9
doch der unterstützt diese funktion..
bin momentan auf funpic und andere user nutzen diese funktion auch
http://www.funpic.de/board/support-f2/um...69152.html
Zitieren
#10
OK. Hast du die Datei direkt ins Hauptverzeichnis geladen oder /forum - vielleicht liegt es daran - versuche sie mal im Hauptverzeichnis hochzuladen. Erstelle die Datei am Besten mit dem Editor - falls nicht schon so gemacht.
Gruß
Marcel
[Bild: pcpedia_banner_332x60.png]
Zitieren