Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Frage zur besten Update-Prozedur
#1
Hi,

ich habe zur Zeit ein doch stark verändertes MyBB 1.4.15 am laufen. Neben dem Theme sind auch viele Templates bearbeitet. Dazu kommen noch einige Plugins.
Nun würde ich gerne auf MyBB 1.6.2 umziehen und bin gerade dabei alles vorzubereiten: Theme und Templates, Settings-Datei, etc. erstelle ich gerade in einer Testumgebung, damit ich die dann parat habe.

Meine Frage ist: Wie update ich das Forum am besten? Ich weiß nicht ob alle meine Gedankenkonstrukte funktionieren, aber:
1. Ein sauberes MyBB 1.6.2 installieren, Themes, Templates und Plugins einrichten und dann Posts/User/PNs, etc. importieren (wäre rein gedanklich mein Favorit, damit alles "frisch" ist.
2. MyBB 1.6.2 installieren, ein komplettes Backup der Datenbank einspielen und dann den neuen Wünschen anpassen (Nachteil: Viel alter Müll würde wohl übernommen werden)
3. MyBB 1.4.5 einfach updaten (gleicher Nachteil wie oben, zudem würde der eigentliche Updateprozess recht lange dauern)

Kurzum: Kann man relativ problemlos ein sauberes MyBB 1.6.2 installiern und dann nurnoch die wesentlichen Daten importieren (und welche sind dies?)
#2
Ich rate dir zu einem normalen Upgrade, dann gehen deine ganzen Änderungen und Plugins nicht verloren.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
#3
Einige, oder besser bis auf ein alle Plugins sollen sogar weg oder wurden ausgetauscht. Die Änderungen zu machen, wäre kein großes Problem, ich will nur keine "Matsch-Lösung", bei der ich hier was von 1.4 habe, da was von 1.6 und im Endeffekt läuft es, ist aber gefrickelt.
Für die 1.6 wurde zudem ein komplett neues Design entworfen (hätte ich vllt. erwähnen sollen Wink) -> alle Templates müssen eh geändert werden.
#4
Dann deaktiviere vorher die Plugins, die weg sollen, mache das Upgrade und tausche dann das Theme aus.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.