Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Fehler bei 1&1 (class_error.php on line 51)
#1
Hallo

ich wollte gestern ein MyBB bei mir auf dem Server installieren, was leider nicht so funktioniert hat, wie ich mir das vorgestellt habe.

Ich habe MyBB 1.6.2 Deutsch (22.02.2011) runtergeladen und dann entpackt. Denn Inhalt des Upload Ordners habe ich dann Hochgeladen. Danach wollte ich mit der Installation beginnen, aber beim ersten Aufruf kam folgende Fehlermeldung:
Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /homepages/41/***/htdocs/Foren/net-community Forum/inc/class_error.php on line 51

Zu Testzwecken habe ich das Board dann auf einem anderen Server Hochgeladen, und da Funktionierte die Installation.

Ich will das Forum aber auf meinem Webspace Hochladen. Meinen Webspace habe ich bei 1&1 (1&1 Homepage Perfect)

Hier ist der Link zum Forum: http://forum.net-community.eu/

Ich bitte um Hilfe.

Grüße Steve
#2
Bitte benutze die Suche!
Das MyBB benötigt PHP 5, bei dir läuft aber wohl noch PHP 4.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
#3
Nein bei mir läuft PHP5 und bis zur Eingabe in der Datenbank bin ich nicht mal gekommen.
#4
Dann lade die inc/class_error.php nochmal neu hoch.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
#5
(26.02.2011, 17:04)StefanT schrieb: Dann lade die inc/class_error.php nochmal neu hoch.

habe ich schon. Habe sogar alles noch einmal neu Hochgeladen.
Habe sogar das Funktionierende Installierte Forum als Backup vom anderen Server runtergeladen und dann bei mir Hochgeladen, klappte aber auch nicht.
#6
Dann muss es an der PHP-Version liegen: http://community.mybb.com/thread-88536.html
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
#7
(26.02.2011, 17:52)StefanT schrieb: Dann muss es an der PHP-Version liegen: http://community.mybb.com/thread-88536.html

Ich gucke da noch einmal genauer nach, aber ich weiß, das ich eine PHP 5 MySQL Datenbank habe.

Danke erstmal.
#8
MySQL 5 oder PHP 5?
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
#9
(26.02.2011, 18:02)StefanT schrieb: MySQL 5 oder PHP 5?

PHP5

Ich nutze ein anders Forum, in dem ich Mods eingebaut habe, die PHP 5 benötigen, und die laufen. Aber ich gucke mal welche Version ich genau habe und ob ich diese ggf. erhöhen kann.

Gruß Steve
#10
Standardmäßig läuft bei den 1und1 Webpaketen PHP4.
Die Umstellung auf PHP5 muss dort per .htaccess vorgenommen werden.

http://hilfe-center.1und1.de/hosting/scr...hp/17.html