Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
[gelöst] - von ACP zurück zu Forum macht Probleme
#1
Moin moin,

ich habe kein ähnliches Problem finden können.
Problem:
Wenn ich im Admin CP bin und von heraus zurück auf die Hauptseite möchte (oben rechts - Link "Forum ansehen"), lande ich auf meinem übergeordneten Blog.
A) taiji.blogsite.org/forum2/index.php wäre korrekt
B) stattdessen lande ich auf taiji.blogsite.org/forum2

Ich gehe davon aus, das es eine Fehleinstellung meines Apache2 ist, finde aber den entsprechenden Punkt nicht (virtual-server ???).
Ich fahre meinen eigenen Server und habe somit volle root Rechte.

Ohne am Apache zu konfigurieren könnte ich es lösen, wenn ich
Home » Foreneinstellungen » Allgemeine Konfiguration » URL zum Forum » http://taiji.blogsite.org/forum2
... durch den Zusatz index.php ergänzen könnte. Also:
URL zum Forum » http://taiji.blogsite.org/forum2/index.php

Lässt sich das bewerkstelligen? Oder muss ich am Apache rumschrauben?

Liebe Grüsse,
Michael
... es ist alles nur ein Traum ...
© bei mir
#2
Wenn ich bei mir

/forum

oder

/forum/index.php

nehme, ist beides das gleiche

/forum/index.php ist nur die bessere Variante auf eine Seite zu kommen, die du brauchst

Mach nen neuen Ordner, bennen ihn auf forum3, du wirst sehen, das sind beides die gleichen Seiten.


Edit: Fehler meinerseits, bei dir ist es so

Da weiß ich leider gerade keine Lösung, komisch das es bei dir so ist


Ich jedenfalls, kann dieses Problem nicht bestätigen.
#3
Dass bei http://taiji.blogsite.org/forum2/ nicht das MyBB kommt, liegt an deinen Veränderungen. Schließlich kommt normalerweise die index.php.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
#4
Moin StefanT,

das ist so nicht richtig, da es für das Forum eine unveränderte index.php gibt.
So wie ich das sehe, sucht mein Apache zuerst nach einer index.html und sollte dann nach einer index.php suchen .... macht er aber nicht, sondern arbeitet scheinbar wie folgt:
A) Ich, der Apache, gehe auf http://taiji.blogsite.org/forum2/
B) Hier ist keine index.html
C) Weiteres suche ich nicht
D) Ich habe aber eine index.php in meinem Dokumentroot Verzeichnis, also nehme ich diese, weil deren Priorität übergeordnet ist.

Zumindest denke ich mir das so.
Aber ich suche nun seit gestern alles möglich zwischen Apache PHP5 und Forensoftware, inklusive aller htaccess Dateien ab und finde nichts was mich auf die richtige Spur, oder Lösung bringt.
Ein Teufelskreis.

Gruss,
MIchael
... es ist alles nur ein Traum ...
© bei mir
#5
Ah, jetzt verstehe ich das Problem.
Gibt es eine .htaccess bei deinem Blog?
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
#6
Ja gibt es ... wurde vom System erstellt ... hatte ich aber auch schon testweise verschoben.
Hmmm .... gibt es noch eine in Unterzeichnissen?

Options -MultiViews +FollowSymlinks -Indexes
DirectoryIndex index.php index.html portal.php

#
# If mod_security is enabled, attempt to disable it.
# - Note, this will work on the majority of hosts but on
# MediaTemple, it is known to cause random Internal Server
# errors. For MediaTemple, please remove the block below
#
# #<IfModule mod_security.c>
# # # Turn off mod_security filtering.
# # SecFilterEngine Off
# #
# # # The below probably isn't needed, but better safe than sorry.
# # SecFilterScanPOST Off
# #</IfModule>

#
# MyBB "search engine friendly" URL rewrites
# - Note, for these to work with MyBB please make sure you have
# the setting enabled in the Admin CP and you have this file
# named .htaccess
#
# #<IfModule mod_rewrite.c>
# # RewriteEngine on
# # RewriteRule ^forum-([0-9]+)\.html$ forumdisplay.php?fid=$1 [L,QSA]
# # RewriteRule ^forum-([0-9]+)-page-([0-9]+)\.html$ forumdisplay.php?fid=$1&page=$2 [L,QSA]
# #
# # RewriteRule ^thread-([0-9]+)\.html$ showthread.php?tid=$1 [L,QSA]
# # RewriteRule ^thread-([0-9]+)-page-([0-9]+)\.html$ showthread.php?tid=$1&page=$2 [L,QSA]
# # RewriteRule ^thread-([0-9]+)-lastpost\.html$ showthread.php?tid=$1&action=lastpost [L,QSA]
# # RewriteRule ^thread-([0-9]+)-nextnewest\.html$ showthread.php?tid=$1&action=nextnewest [L,QSA]
# # RewriteRule ^thread-([0-9]+)-nextoldest\.html$ showthread.php?tid=$1&action=nextoldest [L,QSA]
# # RewriteRule ^thread-([0-9]+)-newpost\.html$ showthread.php?tid=$1&action=newpost [L,QSA]
# # RewriteRule ^thread-([0-9]+)-post-([0-9]+)\.html$ showthread.php?tid=$1&pid=$2 [L,QSA]
# #
# # RewriteRule ^post-([0-9]+)\.html$ showthread.php?pid=$1 [L,QSA]
# #
# # RewriteRule ^announcement-([0-9]+)\.html$ announcements.php?aid=$1 [L,QSA]
# #
# # RewriteRule ^user-([0-9]+)\.html$ member.php?action=profile&uid=$1 [L,QSA]
# #
# # RewriteRule ^calendar-([0-9]+)\.html$ calendar.php?calendar=$1 [L,QSA]
# # RewriteRule ^calendar-([0-9]+)-year-([0-9]+)\.html$ calendar.php?action=yearview&calendar=$1&year=$2 [L,QSA]
# # RewriteRule ^calendar-([0-9]+)-year-([0-9]+)-month-([0-9]+)\.html$ calendar.php?calendar=$1&year=$2&month=$3 [L,QSA]
# # RewriteRule ^calendar-([0-9]+)-year-([0-9]+)-month-([0-9]+)-day-([0-9]+)\.html$ # #calendar.php?action=dayview&calendar=$1&year=$2&month=$3&day=$4 [L,QSA]
# # RewriteRule ^calendar-([0-9]+)-week-(n?[0-9]+)\.html$ calendar.php?action=weekview&calendar=$1&week=$2 [L,QSA]
# #
# # RewriteRule ^event-([0-9]+)\.html$ calendar.php?action=event&eid=$1 [L,QSA]
# #
# # <IfModule mod_env.c>
# # SetEnv SEO_SUPPORT 1
# # </IfModule>
# #</IfModule>

#
# If Apache is compiled with built in mod_deflade/GZIP support
# then GZIP Javascript, CSS, HTML and XML so they're sent to
# the client faster.
#
# #<IfModule mod_deflate.c>
# # AddOutputFilterByType DEFLATE application/javascript text/css text/html text/xml
# #</IfModule>
... es ist alles nur ein Traum ...
© bei mir
#7
Ich meinte die .htaccess von deinem Blog.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
#8
# BEGIN s9y
DirectoryIndex /index.php
php_value session.use_trans_sid 0
php_value register_globals off

<Files *.tpl.php>
deny from all
</Files>

<Files *.tpl>
deny from all
</Files>

<Files *.sql>
deny from all
</Files>

<Files *.inc.php>
deny from all
</Files>

<Files *.db>
deny from all
</Files>

# END s9y
#SPAMDENY
Deny From 188.194.128.74
#/SPAMDENY
... es ist alles nur ein Traum ...
© bei mir
#9
Da haben wir ja den Übertäter:
Code:
DirectoryIndex /index.php
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
#10
Ich brech zusammen ... trotz Deiner Ansage musste ich dreimal hinschauen bis ich den Eintrag sah ... die Sache mit dem Wald undso.

Tausend Dank ... es läuft nun natürlich.

Liebe Grüsse und einen wunderbaren Tag,
der Micha
... es ist alles nur ein Traum ...
© bei mir


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Instalation macht Probleme Minusch 3 671 23.01.2011, 15:31
Letzter Beitrag: StefanT