Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Problem mit neuer Mysql version
#1
Hallo und guten tag.
Heute habe ich mein forum umgezogen und stellte gleich einen fehler fest. Unser Hoster hat ihre technik aktualisiert und die mysql version ist höher als die mit mybb kompitabel. Ich erhalte diesen fehler:

2000 - mysqlnd cannot connect to MySQL 4.1+ using old authentication

Ich frage mich ob man das problem lösen kann? Und ob vielleicht eine andere Version damit kompitabel ist. Ich glaube ich hab version 1.4 - 1.5.


Vielen Dank für eure Hilfe!
#2
Das ist entweder ein Fehler in der PHP-Erweiterung oder bei MySQL. Da musst du dich an den Hoster wenden.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
#3
Wird wohl an Mysql liegen. Sie haben jetzt die mysql version 5 drauf. Da ihr euch ja gut mit mybb auskennt, wollte ich fragen welche version damit kompitabel wäre. Hoster ist bplaced
#4
Ich denke nicht, dass du da irgendwas machen kannst.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
#5
Wende dich doch an den Support deines Hosters. Soviel wie ich in Erfahrung bringen konnte wird eine alte Authentifizierungsmethode verwendet. Da MySQL5 was neueres verwendet klappt der Zugriff nicht mehr. Ist aber ohne Gewähr da ich nicht der Kenner von MySQL bin. Big Grin

Vielleicht hilft es ja schon ein neues Passwort für die DB zu vergeben. Und natürlich dann auch die config.php anzupassen.
#6
Hallo, ich denke ich habe es doch geschafft. Die Fehlermeldung verschwand nach der änderung des passworts. Ich werde euch aber auf den laufenden halten.