Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Probleme mit Attachments bei IPB 2.3x > mybb 1.4.11 Umzug
#1
Hallo zusammen und ein "Frohes Neues" !

habe mich nach langem noch einmal an die Umzugsthematik vom IPB 2.3.x zum my BB 1.4.11 gewagt.

Sieht jetzt auch schon besser aus, wie zu meinen ersten Versuchen damals.
Jedoch hänge ich noch an den Attachments die in die DB importiert werden (von den Einträgen) nur bei den Dateien harpert es noch...

Als Pfad funktioniert "bei mir" nur der Systempfad auf dem Server, die eigentliche URL des alten Forums wird nicht akzeptiert (habe da die Berechtigungen gesetzt, so das ich per Hand auch Dateien im FF aufrufen kann...).
Der Importvorgagn beginnt ohne Fehler, es werden aber keine Dateien kopiert...
CHMOD ist für Uploads und avatar... jeweils auf 777 ...


Meine Vermutung liegt darin, das es ein Problem in der attachments.php an folgender Stelle gibt... ?!...

PHP-Code:
// Transfer attachment
        
$data_file merge_fetch_remote_file($import_session['uploadspath'].'/'.$data['attach_location']);
        if(!empty(
$data_file))
        {                    
            
$attachrs = @fopen($mybb->settings['uploadspath'].'/'.$insert_data['attachname'], 'w');
            if(
$attachrs)
            {
                @
fwrite($attachrs$data_file);
            }
            else
            {
                
$this->board->set_error_notice_in_progress("Error transfering the attachment (ID: {$aid})");
            }
            @
fclose($attachrs);
            
            @
my_chmod($mybb->settings['uploadspath'].'/'.$insert_data['attachname'], '0777');
            
$attach_not_exists "";
        }
        else
        {
            
$this->board->set_error_notice_in_progress("Error could not find the attachment (ID: {$aid})");
        }
    } 

Mich macht halt nur stutzig, das es keinen Error gibt...

ggf. jemand eine IDee ?! Smile

Gruß Demo
Wissen ist das einzige Gut das sich vermehrt, wenn man es teilt!
#2
Das @ vor einem Funktionsaufruf unterdrückt die Fehlerausgabe. Entferne diese mal und schau dann, ob es eine Fehlermeldung gibt.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#3
Hi Michael,

habe ich gerade noch gemacht, war aber auch schon auf der "richtigen Spur...", glaube ich ... Smile

Code:
Warning [2] fopen(/usr/home/xxxxx/www/xxxxxxxxx/mybb1411/./uploads/) [function.fopen]: failed to open stream: Is a directory - Line: 234 - File: convert/boards/ipb2/attachments.php PHP 5.2.8 (FreeBSD)

wobei mich der "Punkt" irritiert...

fopen(/usr/home/xxxxx/www/xxxxxxxxx/mybb1411/./uploads/

hatte auch schon selbst versucht die Ursache zu suchen... leider bisher ohne Erfolg...


Gruß Demo
Wissen ist das einzige Gut das sich vermehrt, wenn man es teilt!
#4
Das Problem ist, dass hinten der Dateiname fehlt...
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
#5
hmmm...

hatte das mal am Scriptanfang geprüft... und dort ist die Variable $insert_data['attachname'] auch mit dem Dateinamen gefüllt...

In der Funktion "after_insert" jedoch OHNE Inhalt... ?!..
Wissen ist das einzige Gut das sich vermehrt, wenn man es teilt!
#6
Bitte eröffne ein Ticket dazu und schildere deine bisherigen Erkenntnisse. So kann ein Entwickler dabei schauen und den Fehler für alle beheben: http://dev.mybboard.net/projects/mybb-import

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#7
Hi Michael,

habe ich eben mal dort gemeldet, aber bin mir jetzt nicht sicher woher das kommt.

Fakt ist, das die Variable $insert_data['attachname'] keinen Inhalt hat mehr hat... der Aufbau der attachments.php für´s IPB oder... SMF... sieht für mich aber relativ gleich aus...hmmm... bin mal gespannt ob da ein Hinweis oder eine Lösung kommt...

Gruß Demo
Wissen ist das einzige Gut das sich vermehrt, wenn man es teilt!
#8
Warum gleich 3 Tickets?
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
#9
kA. hatte eine 500er Errormeldung nach dem absenden des Forms.... anschliessend konnte ich nicht mehr löschen...
Wissen ist das einzige Gut das sich vermehrt, wenn man es teilt!
#10
Das könnte mit dem Update von Redmine zusammenhängen. Aktuell scheint es aber keine Probleme mehr zu geben.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.