Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
PHP 5.3.0
#1
Wie der Titel schon sagt das mybboard funktioniert nicht mit php 5.3.0

Schuld daran ist das php5.3.0 eine Vorversion zu PHP6 ist und damit befehle wie magic quotes_runtime veraltet sind und nicht mehr funktionieren.

Das nächste Problem ist bei den Board, als Admin kann man sich in die Forensoftware anmelden aber mit einen User Account ist es nicht möglich!

Was daran Schuld ist, sind die kompletten Header fehler, die nicht mehr mit php5.3.0 kompitabel sind.

Gibt es irgendwelche Updates wo diese Fehler fixen?
#2
http://community.mybboard.net/thread-521...#pid372017
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
#3
Die Probleme wo da geschildert wurden und den fixes wo man anwenden sollte, werden dort nicht funktionieren bei mir treten fehler in den Sequenzen auf:

[PHP] errorHandler->error
htdocs\myboard\inc\functions.php 1541 header
htdocs\myboard\inc\class_session.php 360 my_setcookie
htdocs\myboard\inc\class_session.php 98 session->load_guest
htdocs\myboard\global.php 56 session->init
htdocs\myboard\index.php 18 require_once
Warning [2] Cannot modify header information - headers already sent by (output started at htdocs\myboard\index.php:1) - Line: 1541 - File: htdocs\myboard\inc\functions.php PHP 5.3.0 (WINNT)
File Line Function
[PHP] errorHandler->error
htdocs\myboard\inc\functions.php 1541 header
htdocs\myboard\inc\class_session.php 365 my_setcookie
htdocs\myboard\inc\class_session.php 98 session->load_guest
htdocs\myboard\global.php 56 session->init
htdocs\myboard\index.php 18 require_once
Warning [2] Cannot modify header information - headers already sent by (output started at htdocs\myboard\index.php:1) - Line: 1541 - File: htdocs\myboard\inc\functions.php PHP 5.3.0 (WINNT)
File Line Function
[PHP] errorHandler->error
htdocs\myboard\inc\functions.php 1541 header
htdocs\myboard\inc\class_session.php 106 my_setcookie
htdocs\myboard\global.php 56 session->init
htdocs\myboard\index.php 18 require_once

Laut den Link sollte man auch die Errors deaktivieren so das php keine Fehlermeldungen mehr bringt, das wär eine Lösung aber dadurch würde auch eine verbale Sicherheitslücke entstehen.
#4
Wenn du einen geeigneten Editor verwendet, entstehen nicht diese Fehler: https://www.mybb.de/doku/haeufig-gestell...datei.html
Das Unterdrücken von Fehlern ist überhaupt nicht unsicher, allerdings nicht zu empfehlen.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
#5
Hm der normale Texteditor unterstützt doch auch Ansi Formate?
#6
Der macht aber den Mist mit dem BOM-Header... Du siehst ja, was rauskommt. Wink
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
#7
Ok, ich werd es nachher mal mit dem notepad++ probieren. Vielel dank
mfg neti
#8
also bei mir funktioniert dass mybb mit php 5.3 =)
#9
Ja, klar. Toungue
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
#10
bis auf den einen Bug da Wink ne aber so die Grundfunktionen Big Grin