Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
MYBB_ROOT fehler.
#1
PHP-Code:
<?php

require_once(MYBB_ROOT."inc/datahandlers/pm.php");
$pmhandler = new PMDataHandler();

$NICK $_POST["TU1"];
$TU $_POST["TU2"]; // WTF. Ka vllt wegen dem fehlenden ; mal schaun
$TW1 $_POST["TW1"];
$TW2 $_POST["TW2"];
$CHA $_POST["CH1"];
$CHAT $_POST["SY1"];
$sub $_POST['sub'];
$content "Hallo, <br> ein Tauschüberwacher wurde angefordert. <br> Tauschpartner 1: ".$NICK." moechte mit ".$TU." tauschen. <br> Es wird ".$TW1." gegen ".$TW2." getauscht im ".$CHAT." Chat im Channel: ".$CHA." <br>";



if (
$sub == 'Anfrage+absenden')  
{
$pm = array(
        
"subject" => "NEUER TAUSCH",
        
"message" => $content,
        
"fromid" => "24",
        
"to" => array("24"),
        
"options" => array(
                   
"savecopy" => 0,
                   
"readreceipt" => 0
        
)
    );
$pmhandler->set_data($pm); 
if(
$pmhandler->validate_pm())
{
        
$pmhandler->insert_pm();

echo 
"Erfolgreich abgesendet";


?>
Es kommt dieser Fehlermeldung:
PHP-Code:
Warning: require_once(MYBB_ROOTinc/datahandlers/pm.php) [function.require-once]: failed to open streamNo such file or directory in /mnt/web4/23/03/52153003/htdocs/tausch2.php on line 3

Fatal error
: require_once() [function.require]: Failed opening required 'MYBB_ROOTinc/datahandlers/pm.php' (include_path='.:/opt/RZphp5/includes'in /mnt/web4/23/03/52153003/htdocs/tausch2.php on line 3 
Ich glaube, man muss noch etwas importieren damit das script weis was MYBB_ROOT ist oder was muss ich machen? Das soll ein Tauschsystem werden.
#2
https://www.mybb.de/doku/haeufig-gestell...ellen.html Toungue
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.