Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Grafik wird nicht angezeigt
#1
Ich habe ein Impressum PlugIn bei mir eingespeilt, funktioniert eigentlich auch ganz gut, nur die Grafik wird nicht angzeigt. ICh kenn mich nun leider 0 mit php aus, und wollte mal fragen was an dem Script falsch ist:

hier mal der Teil wo die Grafik beschrieben ist:

PHP-Code:
    // Attempt to modify header template
    
require_once MYBB_ROOT."/inc/adminfunctions_templates.php";
    
find_replace_templatesets("header"'#toplinks_help}</a></li>#'"$0\n<li class=\"impressum_link\"><a href=\"{\$mybb->settings['bburl']}/misc.php?action=impressum\"><img src=\"{\$theme['imgdir']}/toplinks/impressum.gif\" border=\"0\" alt=\"\" />Impressum</a></li>"); 

das Image liegt im Ordner toplinks --warum wird die Grafik nicht angezeigt?
Das Wettfoum im deutschsprachigen Raum. SportwettenTALK.com
#2
Hallo sportwettentalk,

verwendest du ein weiteres Theme (evtl. "cleancut")? Liegt die Grafik "impressum.gif" dann im Verzeichnis ".../images/cleancut/toplinks"?
Code:
...
<img src=\"{\$theme['imgdir']}/toplinks/impressum.gif\" border=\"0\" alt=\"\" />
...
Die Variable {\$theme['imgdir']}/... steht hierbei für images/dein_theme/....
#3
In dem Code wird das Template "header" geändert. Bitte suche dort nach dem Fehler. Im PHP-Code kannst du eigentlich nichts machen.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
#4
nope, genau das war es. Vielen Dank - bin begeistert wie schnell hier kompetente Hilfe kommt...und das auch ohne blöde Sprüche wenn man mal nicht so fit ist mit php....Danköööö
Das Wettfoum im deutschsprachigen Raum. SportwettenTALK.com