Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Nach Upgrade 1.4.04 folgende Meldung...
#1
Hi,
brauche Hilfe...

Hab eben mein Forum upgedated. Hab dann auch den Installordner gelöscht.

Jetzt kommt folgende Meldung...

Zitat:MyBB has experienced an internal error and cannot continue.

Error Type:
MyBB Error (40)
Error Message:
Your board has not yet been upgraded. Please do so before attempting to browse it.

Scheibenkleister... was nun ?

Grüße Jörg
#2
Der Install Ordner müsste sich ja noch auf dem PC befinden nach dem Entpacken.
Sollte doch möglich sein, den wieder ins Forum-Verzeichnis zu laden und den Pfad: -/forum/install/upgrade.php im Browser einzugeben?
#3
Ohhh Mann..

ich hab das Upgradescript erneut ausgeführt....

Gleicher Fehler.??

Also das Upgrade ist ganz durchgelaufen.... hab dann Install gelöscht. Dann kommt der Fehler.

*Edit: Kann es an einer veralteten "Config.php" liegen ? Wenn ja - was dann wenn ich die aktuelle nicht vorliegen habe ?

Grüße Jörg
#4
Es kann eine Rolle spielen von welcher Version auf 1.4.4 upgegradet wurde.
Ich bin zu wenig versiert, um weiter zu helfen. Es gibt hier hervorragende Supportleute. In der Zweischenzeit versuch mal mit der Suchfunktion abzuklären, was da schon alles für Probleme aufgetaucht sind und gelöst wurden.
#5
Hi,

Danke für deine Hilfe - nutze die ganze Zeit schon die Suchfunktion aber find nichts brauchbares. Hab so wie es aussieht die Config und Settings Datei ausversehen gelöscht *grrmmppf* und jetzt hab ich nur noch ne alte Config und Settings Datei da.

Eventuell liegt es daran ?

Vielleicht weiss ja noch einer was ich machen kann das das Forum wieder funzt.

Grüße Jörg
#6
Bei einem Upgrade kann immer etwas schief laufen. Die Leute hier empfehlen, ein Serverbackup zu machen wie es von vielen hostern angeboten wird, dann spielt man das Backup zurück und versuchts nochmals.

Manchmal ist es die zweckmässigste Lösung eine Neuinstallation durchzuführen. Mit folgemdem Download rechts oben ist eine Vollversion installierbar. Wart aber noch ab, vielleicht kennt ein Supporter dein Problem und es ist lösbar.

Link zum Download der Vollversion:
https://www.mybb.de/downloads.html
#7
Hi,

ok ich warte auf jeden Fall noch ab.

Andere Frage... wenn ich an der Datenbank nichts gemacht habe und eine Nagelneue Installation von 1.4.4 draufspiele... sind dann meine Daten noch da ? Also die Einträge im Forum ? Im Normalfall macht man ja BackUps von Serverstruktur und Datenbank.

Es gibt ein Backup aber das ist schon etwas älter.

Ich muss mich unbedingt mit Datenbanken beschäftigen merke ich gerade Sad Manchmal siegt der Leichtsinn und jetzt hab ich den Salat.

Ich hoffe nur das ich das diesesmal noch hinbekomme - und dann unbedingt BackUp ziehen und lernen wie man das mit der Datenbank auch macht ?!

Grüße Jörg
#8
Sind bei einer Neuinstallation die Daten noch da? Grundsätzlich ja, es wird bei der Installation nach den Einstellungen für die Datenbank gefragt, die musst Du genau kennen und exakt eingeben, Name der Datenbank, lokalhost, Benutzer, Passwort, all diese Angaben müssen auf die bisherige Datenbank verweisen, oft erkennt das System die alte Datenbank und fragt einfach, ob es die übernehmen soll oder ob sie gelöscht werden sollen und eine neue Datenbank erstellt werden soll.

Dann kommt mir noch in den Sinn, wenn Plugins installiert sind, die nicht kompatibel sind mit 1.4.4 (das sind eigentlich alle) müssen die vorher inaktiviert werden. Sie lassen sich dann später aktualisieren mit den kompatiblen Versionen.

Dann noch eine Frage: kommst Du noch ins Admin-CP mit dem Pfad -/forum/admin/index.php ?
#9
OK,
die Daten kenn ich ... das wäre also nicht das Problem im Ernstfall.

Bei den PlugIns ist es aber doch auch so das wenn man z.B. einige ( "Thema erledigt" glaube ich war es - deaktiviert - verlieren sich die ganzen "Markierungen der erledigten Themen". Das ist dann natürlich ärgerlich.

Jetzt heißt es Daumen drücken und hoffen !

So... mein Kumpel hat nun die Lösung für unser Problem gefunden. Für alle die es noch interessiert hier die Lösung meines Problems...

Kleine Änderungen an 3 Dateien... das untenstehende auf eigene Gefahr. Ich zitiere nur aus einer Email von ihm...

Zitat:1. moderation.php
===============

Find:
--
// Begin!
switch($mybb->input['action'])
{
--

ADD BEFORE:
--
if($mybb->request_method != "post" && $mybb->input['action'] != "getip")
{
error_no_permission();
}
--

===============
2. (If you are not planning to run the upgrade procedureSmile For each of your template sets under the "showthread_moderationoptions" template
===============

Find:
--
<form action="moderation.php" method="get" style="margin-top: 0; margin-bottom: 0;">
--

Replace with:
--
<form action="moderation.php" method="post" style="margin-top: 0; margin-bottom: 0;" id="moderator_options">
--
Also Find:
--
<select name="action" onchange="window.location=('moderation.php?action='+this.options[this.selectedIndex].value+'&amp;tid={$tid}&amp;modtype=thread&amp;my_post_key={$mybb->post_code}')">
--

Replace with:
--
<select name="action" onchange="$('moderator_options').submit();">
--

===============
3. inc/class_core.php (Version number change)
===============

Find:
--
/**
* The friendly version number of MyBB we're running.
*
* @var string
*/
var $version = "1.4.3";

/**
* The version code of MyBB we're running.
*
* @var integer
*/
var $version_code = 1403;
--

Replace with:
--
/**
* The friendly version number of MyBB we're running.
*
* @var string
*/
var $version = "1.4.4";

/**
* The version code of MyBB we're running.
*
* @var integer
*/
var $version_code = 1404;
--

Weiss nicht wo er es gefunden hat - aber ich denke das es vielleicht für den ein oder anderen sehr hilfreich ein könnte.

Danke nochmals an Cybercrash !!

Grüße Jörg
#10
Das ist die manuelle Patch-Anleitung für MyBB 1.4.4, die es auch in der Ankündigung gibt!?

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.