Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
ACP nur bedingt möglich, kann Einstellungen nicht speichern
#1
Hallo!

Ich wollte nun, nachdem ich mir meine Seite samt Forum lokal eingerichtet habe, den ganzen Spaß auf meinen Webserver hochladen. Nachdem ich nun einige Sachen selbst korrigieren konnte, hänge ich bei einem großen Problem.

Ich habe einfach die Datenbank kopiert und auf dem webserver wieder importiert, das ist alles auch soweit garkein Problem. Nur stimmen die URLs nicht. Ich kann mich auch im ACP einloggen, allerdings werden nach jedem Klick die Benutzerdaten erneut abgefragt und wenn ich versuche die URL zu ändern, speichert er die vorgenommen Änderungen nicht. Das mit dem Login wird dann wahrscheinlich auch an der falschen cookie url liegen.

Beim Hochladen habe ich mich übrigens an den Guide aus der Dokumentation gehalten. Die letzteren Punkte lassen sich aber nicht realisieren.

Über jegliche Hilfe würde ich mich sehr freuen Smile .

beste Grüße
-dave
#2
Hallo JBeh,

welchen Browser nutzt du?
Solltest du Opera nutzen hilft eventuell folgendes:
Sobald du nach dem einloggen wieder aufgefordert wirst dich einzuloggen, drücke einmal die F5 Taste und du bist wieder eingeloggt. Das ganze wird vermutlich durch das Caching des Browsers hervorgerufen.

Mfg Garlant
Ich gebe keinen Support per Messenger oder PN!
#3
Danke für die schnelle Antowort. Ich benutze tatsächlich Opera, mit Firefox tritt allerdings das gleiche Problem auf... habe auch den Cache geleert und dann nochmal neu geladen aber es nutzt alles nichts. Was ich nun wiederum aber nicht verstehe ist, dass die Links zu den einzelnen Foren und Kategorien korrekt sind, alle anderen aber nicht.

Welche Möglichkeiten habe ich noch Änderungen an den Einstellungen vornehmen um die URL zu ändern? Habe ebend auch probiert die Settings.php zu ändern, jedoch scheint das keine Auswirkungen zu haben .

beste Grüße
-Dave
#4
Dein Vorgehen mit der "settings.php" ist richtig. Passe dort den Cookie-Pfad (ggf. auch den Präfix) und die Foren-URL an und setze auf dem Server entspr. Schreibrechte für die Datei (CHMOD 777).

Neben dem Browser-Cache musst du auch die Cookies für dein Forum löschen, damit dann die neuen Einstellungen greifen.
 
The User, Formerly Known As "En-Gedi"
 
#5
Nachdem ich mich ausgiebig damit befasst habe, habe ich mich dazu entschieden das gesamte Board nochmal komplett neu aufzusetzen. Also ich hab es jetzt doch auf dem Webspace neu installiert. Jetzt muss ich zwar alle Änderungen und Anpassungen nochmal neu einpflegen aber das ist nicht weiter wild.

Dennoch vielen Dank für die Hilfe!
#6
(07.12.2008, 02:26)JBeh schrieb: ... Jetzt muss ich zwar alle Änderungen und Anpassungen nochmal neu einpflegen aber ...

Willkommen im "Club" ... da bist du nicht der erste und wirst auch nicht der letzte sein Wink
 
The User, Formerly Known As "En-Gedi"