Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
benutzer wird in falschen user eingeloggt.
#1
hallo,

ich hab ein großes problem und zwar loggen sich viele in meinem forum von der schule aus an. dh sie haben nach aussen alle die gleiche ip. nun gibt es damit große probleme (siehe anhang) kann man das irgendwie beheben?

danke, dewey


Angehängte Dateien Thumbnail(s)
   
#2
Die Benutzer-Erkennung läuft über Cookies, nicht über die IP-Adresse.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
#3
hmm, was könnte da also falsch laufen? vl hilft das beim lösen: die computer befinden sich alle über wlan mit dem gleichen router verbunden und sind in einer windows domäne.
#4
Hallo,

mit hoher Wahrscheinlichkeit ist da ein Proxy-Server im Netzerk, welcher den HTML-Content zwischenspeichert.
Das hat den Effekt, dass User 2 z.B. eine Seite zu Gesicht bekommt, die User 1 vorher schonmal angesurft hat. Da die Seiten dynamisch gebaut werden (u.a. der Benutzername im HTML steht), passieren dann halt solche Sachen.

In Schulnetzen sind Proxyserver recht häufig anzutreffen, da Schulen oft nur eine geringe Bandbreite ins Internet haben und ein Proxyserver den Zugriff auf alte/bereits angesurfte Seiten beschleunigt.

Baue mal folgendes in die .htaccess ein und beabachte, ob das hilft:

PHP-Code:
<IfModule mod_expires.c>
    
ExpiresActive On
    ExpiresByType text
/html "now"
    
ExpiresByType text/xml "now"
</IfModule

P.S.: Dafür muss dein Apache aber mod_expires unterstützen!
#5
hallo!

ja wir benutzen einen proxy. ich werde das morgen einbauen und dann berichten Smile

danke schonmal für die hilfe.
#6
mach ich das so richtig:

   

und dann die datei auf den server kopieren und in ".htaccess" umbenennen?

edit: hab das jetzt gemacht dann kommt aber ein internal server error 500 wenn ich die seite aufrufe Smile
#7
Gehe mal im Admin-CP in die Server- und Optimierungsoptionen und stelle sicher, dass die No-Cache Header-Option aktiv ist. Fraglich ist aber, ob der Proxy darauf reagiert.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#8
also die option war deaktiviert. habe sie mal aktiviert und werde das morgen testen. und zu der .htaccess, wie muss die ausschauen, dass das richtig funktioniert, weil wie oben gesagt bekomme ich wenn ich die htaccess.txt in .htaccess umbennene einen internal server error Smile
#9
(27.11.2008, 16:07)dewey schrieb: also die option war deaktiviert. habe sie mal aktiviert und werde das morgen testen. und zu der .htaccess, wie muss die ausschauen, dass das richtig funktioniert, weil wie oben gesagt bekomme ich wenn ich die htaccess.txt in .htaccess umbennene einen internal server error Smile

Anscheinend mag dein Apache-Server, so wie er konfiguriert ist, etwas in der .htaccess nicht (bzw. es wurde global verboten vom Hoster).

Da eigentlich alles in Bedingungen steht (If...) müsste es theoretisch nur an dieser Zeile liegen:

PHP-Code:
Options -MultiViews +FollowSymlinks -Indexes 

Deaktivier die mal, indem du eine Raute (#) davorsetzt.
#10
Zum Glück ist es nicht überall so. Wink
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.