Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
tabelle
#1
Hi

kann mir jemand schnell diese tabbele schicken:
Zitat:MyBBMyBB SQL Error
MyBB has experienced an internal SQL error and cannot continue.

SQL Error:
1146 - Table 'marti-gtc_city.forumdatacache' doesn't exist
Query:
SELECT title,cache FROM forumdatacache
Please contact the MyBB Group for support.
Wäre sehr dankbar da ich sie ausversehen nach der instalation gelöscht habe..
Freundliche Grüsse
Marti95.

Die deutsche Rechtschreibung ist Freeware, dass heißt Du darfst sie kostenlos benutzen.
Sie ist allerdings nicht Open Source, dass heißt Du darfst sie weder verändern, noch in veränderter Form veröffentlichen.
#2
Wenn es nur der Cache ist, könntest du die Tabelle neu anlegen. Den Cache kannst du dann im Admin-CP neu builden lassen.

Code:
CREATE TABLE `datacache` (
  `title` varchar(50) NOT NULL default '',
  `cache` mediumtext NOT NULL,
  PRIMARY KEY  (`title`)
) DEFAULT CHARSET=utf8;

datacache müsstest du dann durch deinprefixdatacache ersetzen, deinprefix scheint in deinem fall marti-gtc_city.mybb_forum zu sein, da ich keine forumdatacache tabelle finde?

Bzw. marti-gtc_city. könnte bei dir auch der Datenbankname sein, ich glaube . ist gar kein erlaubtes Zeichen im Prefix, da das ein Datenbanktrenner in SQL ist?
#3
Hi
danke aber ich bin glaub zu blöd dafür
also mein Präfix ist
"forum_"
ich habe eingegeben:
Zitat:CREATE TABLE `forum_` (
`title` varchar(50) NOT NULL default '',
`cache` mediumtext NOT NULL,
PRIMARY KEY (`title`)
) DEFAULT CHARSET=utf8;
geht aber nicht
Freundliche Grüsse
Marti95.

Die deutsche Rechtschreibung ist Freeware, dass heißt Du darfst sie kostenlos benutzen.
Sie ist allerdings nicht Open Source, dass heißt Du darfst sie weder verändern, noch in veränderter Form veröffentlichen.
#4
Hallo Marti95.,

versuch's 'mal hiermit
Code:
CREATE TABLE `forum_datacache` (
  `title` varchar(50) NOT NULL default '',
  `cache` mediumtext NOT NULL,
  PRIMARY KEY (`title`)
) DEFAULT CHARSET=utf8;
#5
mom ich sehe gerade das die datei bereits vorhanden ist aber wiso geht das ned?
Mein config datei ist:
PHP-Code:
/**
 * Database configuration
 *
 * Please see the MyBB Wiki for advanced
 * database configuration for larger installations
 * http://wiki.mybboard.net/
 */

$config['database']['type'] = 'mysql';
$config['database']['database'] = 'marti-gtc_city';
$config['database']['table_prefix'] = 'forum';

$config['database']['hostname'] = 'localhost';
$config['database']['username'] = 'marti-gtc_city';
$config['database']['password'] = 'PASSWORD';

/**
 * Admin CP directory
 *  For security reasons, it is recommended you
 *  rename your Admin CP directory. You then need
 *  to adjust the value below to point to the
 *  new directory.
 */

$config['admin_dir'] = 'admin';

/**
 * Hide all Admin CP links
 *  If you wish to hide all Admin CP links
 *  on the front end of the board after
 *  renaming your Admin CP directory, set this
 *  to 1.
 */

$config['hide_admin_links'] = 0;

/**
 * Data-cache configuration
 *  The data cache is a temporary cache
 *  of the most commonly accessed data in MyBB.
 *  By default, the database is used to store this data.
 *
 *  If you wish to use the file system (cache/ directory), MemCache or eAccelerator
 *  you can change the value below to 'files', 'memcache' or 'eaccelerator' from 'db'.
 */

$config['cache_store'] = 'db';

/**
 * Memcache configuration
 *  If you are using memcache as your data-cache,
 *  you need to configure the hostname and port
 *  of your memcache server below.
 *
 * If not using memcache, ignore this section.
 */

$config['memcache_host'] = 'localhost';
$config['memcache_port'] = 11211;

/**
 * Super Administrators
 *  A comma separated list of user IDs who cannot
 *  be edited, deleted or banned in the Admin CP.
 *  The administrator permissions for these users
 *  cannot be altered either.
 */

$config['super_admins'] = '1';

/**
 * Database Encoding
 *  If you wish to set an encoding for MyBB uncomment 
 *  the line below (if it isn't already) and change
 *  the current value to the mysql charset:
 *  http://dev.mysql.com/doc/refman/5.1/en/charset-mysql.html
 */

$config['database']['encoding'] = 'utf8';

/**
 * Automatic Log Pruning
 *  The MyBB task system can automatically prune
 *  various log files created by MyBB.
 *  To enable this functionality for the logs below, set the
 *  the number of days before each log should be pruned.
 *  If you set the value to 0, the logs will not be pruned.
 */

$config['log_pruning'] = array(
    
'admin_logs' => 365// Administrator logs
    
'mod_logs' => 365// Moderator logs
    
'task_logs' => 30// Scheduled task logs
    
'mail_logs' => 180// Mail error logs
    
'user_mail_logs' => 180// User mail logs
    
'promotion_logs' => 180 // Promotion logs
);
 
?>
Der datei name im phpmyadmin lautet:
forum_NAME
Freundliche Grüsse
Marti95.

Die deutsche Rechtschreibung ist Freeware, dass heißt Du darfst sie kostenlos benutzen.
Sie ist allerdings nicht Open Source, dass heißt Du darfst sie weder verändern, noch in veränderter Form veröffentlichen.
#6
Ah, sorry, bei mir hat sich da ein mybb_ reingemogelt.

Und du hast datacache durch deinprefix ersetzt anstatt durch deinprefixdatacache.

Config sieht okay aus, und wenn du die Table aus versehen gelöscht hast musst du sie halt wieder anlegen?
#7
wie gesagt sie ist noch vorhanden..
wen ich der präfix von der config datei mit forum_ ersetzte wird alles weiss...
aber sonst weiss ich nich wiso es nicht geht!
bite helft mir!
Freundliche Grüsse
Marti95.

Die deutsche Rechtschreibung ist Freeware, dass heißt Du darfst sie kostenlos benutzen.
Sie ist allerdings nicht Open Source, dass heißt Du darfst sie weder verändern, noch in veränderter Form veröffentlichen.
#8
Lass die config.php wie sie ist. Führe dann nochmal den Code aus, den linwinman gepostet hat und nimm aber bei forum_datacache den Unterstrich raus.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#9
Hi

da nichts hilf habe ich ne neu instalation durchgeführt nun geht aber alles wieder...
Freundliche Grüsse
Marti95.

Die deutsche Rechtschreibung ist Freeware, dass heißt Du darfst sie kostenlos benutzen.
Sie ist allerdings nicht Open Source, dass heißt Du darfst sie weder verändern, noch in veränderter Form veröffentlichen.