Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Falsche Attachment-Konstante
#1
Hi,

meine User bekommen die Meldung "Sorry, du kannst dieses Attachment nicht anhängen, weil dein Speicherplatz von 250 KB belegt ist."

In allen Gruppen ist aber 1 GB angezeigt (siehe Attachment), bei mir stimmt es auch. Ich bin absolut ratlos. Es sind mehrere User und ich find nicht wo die 250 KB herkommen.

   

Ich mach damit schon 2 Wochen rum, langsam wirds peinlich.
#2
Hast du die Änderungen direkt in der Datenbank vorgenommen? Aktualisiere mal den Cache usergroups und schau, ob es dann geht.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#3
Ja, unter anderem auch, zuerst aber über die Admin-CP. Ich hab den Cache jetzt für die usergroups mal neu bilden lassen und kann auch die korrekten Werte unter Details sehen. Mal sehen, was die Rückmeldung der User ergibt.

Aber was mir aufgefallen ist: kann es sein, dass mir hier ein paar Caches fehlen:

update_check 149 Bytes
most_viewed_threads 509 Bytes
reportedposts 69 Bytes
most_replied_threads 505 Bytes
stats 130 Bytes
mailqueue 77 Bytes
usergroups 19.43 KB
forumpermissions 59.22 KB

Das müsste doch mehr sein, oder ? Wie krieg ich das wieder hergestellt?

Danke im voraus
Karl
#4
Normalerweise werden die Caches erstellt, wenn sie benötigt werden, aber nicht vorhanden sind. Ist dein Cache in der Datenbank oder in Dateien?

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#5
Als Dateien im Ordner /inc/cache. Hab ich jetzt auch grad mal gelöscht und die Cachefiles werden auch neu erstellt. Ich meinte aber das waren früher mehr. (Kann auch sein, dass ich mich täusche, ich hab 1.2.13 hier).

Wegen dem Upload hab ich leider noch keine Rückmeldung bekommen.

Gruss
Ich dachte grad, ich deaktiviere mal die Statistik-Plugins und da kommt diese Meldung:

"Warning: Call-time pass-by-reference has been deprecated; If you would like to pass it by reference, modify the declaration of [runtime function name](). If you would like to enable call-time pass-by-reference, you can set allow_call_time_pass_reference to true in your INI file in /home/www/web444/html/forum/inc/plugins/pmonreg.php on line 121"

Und ich seh auch keinen Cache für die geladenen Plug-Ins? Hilft das ?
#6
Die Fehlermeldung hat nichts mit dem fehlenden Cache zu tun. Allerdings gibt es bei dir tatsächlich zu wenige Caches. Ändert es etwas, wenn du den Cache in die Datenbank schreiben lässt?

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#7
Also: Uploads gehen wieder, lag also offenbar am usergroup-Cache.

Aber es sind zu wenig Caches da, egal ob ich auf das Filesystem oder in die DB schreiben lasse.
Auswirkung z. B.: die Usermap geht nicht mehr. Ich krieg das kotzen!

Woran kann das liegen? Wir hatten ausser dem Anlegen einiger Mods und Usergroups keine wesentlichen Änderungen vorgenommen.

Schönes Weekend
Karl
Ich hab jetzt mal die Cachedateien von der Testmaschine rüberkopiert und solange gelöscht, rumgespielt und neu bilden lassen, bis soweit alles wieder ging. Aber die Effekte sind verheerend (z. b. fehlende Foren in der Themenanzeige usw.).
#8
Normalerweise wird bei jedem Aufruf eines Caches geprüft, ob dieser existiert. Ist das nicht der Fall, wird er generiert. Ein allgemeines Problem ist nicht bekannt. Kannst du eingrenzen, seit wann es das Problem bei dir gibt? Hast du ein Mod/Plugin installiert, dass etwas damit zu tun haben könnte?

Zu der oben genannten Fehlermeldung: Welche PHP-Version ist auf dem Server vorhanden? Hast du die Möglichkeit die php.ini zu bearbeiten? Fass ja, setze bitte allow_call_time_pass_reference = On.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#9
Hallo Michael,

ja, die Variable steht auf OFF, ich hab jetzt den Support gebeten die Einstellung umzuändern. Ich hoff nur, dass sich da jetzt am Weekend jemand drum kümmert. Über ne .htaccess-Direktive lässt sich das nicht ändern, oder ?
Im übrigen: PHP ist 5.2.6.

An den Erweiterungen kann es nicht liegen, da hat sich seit längerem nichts geändert.
#10
(20.09.2008, 12:53)khkcon schrieb: Über ne .htaccess-Direktive lässt sich das nicht ändern, oder ?
Das ist technisch möglich. Bei normalen Hostern geht das meistens aber nicht.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.