Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
MyBB 1.4.2 veröffentlicht
#1
MyBB 1.4.2 wurde veröffentlicht und steht ab sofort zum Herunterladen bereit. Es handelt sich um ein Sicherheits- und Wartungsupdate, das mehrere Sicherheitslücke mit unterschiedlich hohen Risiken schließt. Zudem wurden über 70 gemeldete Fehler behoben.

Diese Version wurde vom Sicherheitsdienstleister GulfTech auf Sicherheitsprobleme und Verbesserungsmöglichkeiten untersucht.

Diese Sicherheitslücken betreffen MyBB 1.4.1 und ältere Versionen der 1.2er-Reihe. Ältere Versionen könnten ebenfalls betroffen sein. Ein Patch für MyBB 1.2.14 befindet sich weiter unten in dieser Ankündigung.

Informationen zum Update, zu Templateänderungen und zu Änderungen in den Sprachdateien befinden sich in den nächsten Beiträgen.

MyBB 1.4.1 zu 1.4.2 Patch
Der beigefügte Patch ist für Benutzer von MyBB 1.4.1. Sollte eine ältere Version eingesetzt werden ist das Gesamtpaket MyBB 1.4.2 herunterzuladen und ein Upgrade durchzuführen.

Lade das angefügte ZIP-Archiv herunter und entpacke es. Ersetze die Dateien auf dem Server mit den neuen aus dem Archiv.

.zip   mybb_1402_changed_files.zip (Größe: 581,01 KB / Downloads: 563)

Solltest du ein manuelles Update bevorzugen, lade die Datei mybb_1401_patches.txt herunter und folge den enthaltenen Anweisungen.

.txt   mybb_1401_patches.txt (Größe: 6,88 KB / Downloads: 614)

Für die Aktualisierung von MyBB 1.4.1 auf 1.4.2 ist die Ausführung des Upgradeskripts erforderlich, um die Standardtemplates zu aktualisieren. Beachte, dass durch das Einspielen des manuellen Patches nur die Sicherheitslücken mit hohem und mittlerem Risiko geschlossen werden. Solltet ihr euer Forum nicht sofort aktualisieren können, ist das eine temporäre Lösung. Wir empfehlen die Aktualisierung schnellstmöglich vorzunehmen.

Melden von Sicherheitsproblemen
Solltest du ein Sicherheitsproblem im Code des MyBB finden, poste dieses bitte NICHT im Forum. Melde das Problem stattdessen über das Kontaktformular oder per PN an ein Mitglied des Support-Teams.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren
#2
MyBB 1.2.14 Patch
Der beigefügte Patch ist für Benutzer von MyBB 1.2.14 oder ältere Versionen der 1.2er Serie.

Lade bitte die Datei mybb_1214_patches.txt herunter und folge den enthaltenen Anweisungen.

Wir empfehlen allen Benutzern, die noch die 1.2er Serie einsetzen ein Upgrade auf die aktuelle Version (1.4.2).


Angehängte Dateien
.txt   mybb_1214_patches.txt (Größe: 2,71 KB / Downloads: 424)

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren
#3
Aktualisierung von MyBB 1.4.x
Bei der Aktualisierung gehen keine eigenen Themes, Plugins und Sprachpakete verloren.

Führt ein normales Upgrade durch.

Aktualisierung von vorigen Versionen
Bei der Aktualisierung gehen eigene Plugins und Sprachpakete verloren. Es wird versucht eigene Themes zu übernehmen.

Sichert vorher alle Dateien des Forums und die Datenbank! So kann das Forum im Notfall wiederhergestellt werden.

Führt ein normales Upgrade durch.

Geänderte Dateien seit MyBB 1.4.1
  • admin/
    • inc/
      • class_page.php **
      • functions.php
    • index.php
    • jscripts/
      • codepress/
        • codepress.js
    • modules/
      • config/
        • mycode.php
        • plugins.php
        • settings.php
      • forum/
        • announcements.php
        • attachments.php *
        • management.php
      • home/
        • index.php
        • module_meta.php
      • style/
        • templates.php *
        • themes.php
      • user/
        • groups.php *
        • mass_mail.php
        • module_meta.php
        • users.php
  • install/
    • resources/
      • mybb_theme.xml
      • mysql_db_tables.php
      • sqlite_db_tables.php
      • upgrade12.php
      • upgrade13.php
    • upgrade.php
  • inc/
    • class_core.php
    • class_error.php *
    • class_mailhandler.php
    • class_moderation.php **
    • datahandlers/
      • pm.php
      • post.php **
      • user.php
    • db_mysqli.php
    • functions.php **
    • functions_calendar.php
    • functions_compat.php
    • functions_forumlist.php
    • functions_indicators.php
    • functions_modcp.php
    • functions_post.php
    • functions_search.php
    • languages/
      • english/
        • admin/
        • showthread.lang.php
      • english.php
    • mailhandlers/
      • php.php
    • plugins/
      • akismet.php *
    • tasks/
      • dailycleanup.php
      • promotions.php
      • usercleanup.php
  • jscripts/
    • editor_themes/
      • default/
        • images/
      • Office_2007/
        • images/
    • general.js
  • announcements.php *
  • attachment.php **
  • editpost.php
  • forumdisplay.php
  • global.php ***
  • index.php
  • member.php
  • modcp.php *
  • moderation.php *
  • newreply.php *
  • newthread.php
  • polls.php ***
  • private.php *
  • search.php
  • showthread.php
  • usercp.php **
  • warnings.php
  • xmlhttp.php
In rot markierten Dateien wurden Sicherheitslücken geschlossen. Diese Dateien müssen aktualisiert werden.
Grün markierte Dateien sind neu.
Grau markierte Dateien wurden entfernt.
* Datei behebt Sicherheitslücke mit geringem Risiko
** Datei behebt Sicherheitslücke mit mittlerem Risiko
*** Datei behebt Sicherheitslücke mit hohem Risiko

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren
#4
Theme- und Templateänderungen
Seit MyBB 1.4.0 haben sich die folgenden Templates geändert. "Rücksetzung erforderlich" bedeutet, dass dieses Template zurückgesetzt werden muss oder die Änderungen manuell in die Templates eingefügt werden müssen, damit MyBB 1.4.1 korrekt funktioniert. Ist eine Rücksetzung nicht erforderlich, stehen alle Funktionen auch ohne ein Update des Templates zur Verfügung.

Geht nach dem Ausführen des Upgradeskripts ins Admin-CP und sucht nach aktualisierten Templates. Setzt die gefundenen Templates zurück in den Originalzustand oder lasst euch die Änderungen anzeigen und fügt diese manuell ein.
  • private_send
  • polls_showresults_resultbit
  • showthread_poll_resultbit
  • search
  • postbit_attachments_attachment_unapproved
  • calendar_addevent
  • calendar_eventbit_private
  • calendar_eventbit
  • calendar_editevent
  • calendar_move
  • warnings_warn_pm

Sprachpaketänderungen
Seit MyBB 1.4.1 wurden folgende Sprachdateien geändert:
  • admin/config_settings.lang.php
  • showthread.lang.php

Die deutschen Sprachpakete wurden aktualisiert und stehen in einer neuen Version zum Herunterladen bereit. Eine Aktualisierung ist empfehlenswert, da zudem viele Korrekturen vorgenommen wurden.

Plugins
Plugins aus MyBB 1.4.x sollten auch unter 1.4.2 funktionieren.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren
#5
Diskussion zur Ankündigung

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren
#6
Solltet ihr immer noch das Problem mit doppelten Einstellungen haben, findet ihr hier ein Skript, das das Problem behebt. Ihr müsst die Datei in den Ordner des Forums hochladen und im Browser aufrufen. Danach sollte die Datei unbedingt wieder gelöscht werden.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren