Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
MyCode eingebunden
#1
Ich wollte meinen MyCode einbinden leider ist jetzt die ganze Leiste weg!:
Das ist ein Teil der editor.js Datei
PHP-Code:
                {type'button'name'b'sprite'bold'insert'b'titlethis.options.lang.title_bold},
                {
type'button'name'i'sprite'italic'insert'i'titlethis.options.lang.title_italic},
                {
type'button'name'u'sprite'underline'insert'u'titlethis.options.lang.title_underline},
                {
type'separator'},
                {
type'button'name'align_left'sprite'align_left'insert'align'extra'left'titlethis.options.lang.title_left},
                {
type'button'name'align_center'sprite'align_center'insert'align'extra'center'titlethis.options.lang.title_center},
                {
type'button'name'align_right'sprite'align_right'insert'align'extra'right'titlethis.options.lang.title_right},
                {
type'button'name'align_justify'sprite'align_justify'insert'align'extra'justify'titlethis.options.lang.title_justify}
                {
type'separator'},
                {
type'button'name'player'sprite'player'insert'player'titlethis.options.lang.title_player},
                {
type'button'name'ally'sprite'ally'insert'ally'titlethis.options.lang.title_ally},
                {
type'village'name'village'sprite'village'insert'village'titlethis.options.lang.title_village},
                {
type'gidf'name'gidf'sprite'gidf'insert'gidf'titlethis.options.lang.title_gidf}
            ]
        });

        
// Create our new text area
        
areaContainer document.createElement("div");
        
areaContainer.style.clear "both"
Und das Stysheet.css datei:
PHP-Code:
.messageEditor .toolbar_button .toolbar_sprite_align_center {
    
background-position: -92px 0;
}

.
messageEditor .toolbar_button .toolbar_sprite_align_right {
    
background-position: -115px 0;
}

.
messageEditor .toolbar_button .toolbar_sprite_align_justify {
    
background-position: -138px 0;
}
.
messageEditor .toolbar_button .toolbar_sprite_player {
    
backgroundurl(images/player.gifno-repeat;
}
.
messageEditor .toolbar_button .toolbar_sprite_ally {
    
backgroundurl(images/ally.gifno-repeat;
}
.
messageEditor .toolbar_button .toolbar_sprite_village {
    
backgroundurl(images/village.gifno-repeat;
}
.
messageEditor .toolbar_button .toolbar_sprite_gidf {
    
backgroundurl(images/gidf.gifno-repeat;
}

.
messageEditor .toolbar_button .toolbar_sprite_list_num {
    
background-position: -161px 0;
}

.
messageEditor .toolbar_button .toolbar_sprite_list_bullet {
    
background-position: -184px 0

Könnt ihr mir nicht BITTE helfen?
Das [mehr] bei den Smileys funktioniert auch nicht mehr!
#2
Auf den ersten Blick fehlt am Ende dieser Zeile ein Komma:
Code:
{type: 'button', name: 'align_justify', sprite: 'align_justify', insert: 'align', extra: 'justify', title: this.options.lang.title_justify}

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#3
PHP-Code:
{type'button'name'b'sprite'bold'insert'b'titlethis.options.lang.title_bold},
                {
type'button'name'i'sprite'italic'insert'i'titlethis.options.lang.title_italic},
                {
type'button'name'u'sprite'underline'insert'u'titlethis.options.lang.title_underline},
                {
type'separator'},
                {
type'button'name'align_left'sprite'align_left'insert'align'extra'left'titlethis.options.lang.title_left},
                {
type'button'name'align_center'sprite'align_center'insert'align'extra'center'titlethis.options.lang.title_center},
                {
type'button'name'align_right'sprite'align_right'insert'align'extra'right'titlethis.options.lang.title_right},
                {
type'button'name'align_justify'sprite'align_justify'insert'align'extra'justify'titlethis.options.lang.title_justify},
                {
type'separator'},
                {
type'button'name'player'sprite'player'insert'player'titlethis.options.lang.title_player},
                {
type'button'name'ally'sprite'ally'insert'ally'titlethis.options.lang.title_ally},
                {
type'village'name'village'sprite'village'insert'village'titlethis.options.lang.title_village},
                {
type'gidf'name'gidf'sprite'gidf'insert'gidf'titlethis.options.lang.title_gidf},
            ]
        }); 
Aktueller Code^^
Keine Veränderungen zu sehen!
#4
Hast du mal den Cache des Browser geleert? Kannst du einen Link posten, wo das Problem zu sehen ist?

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#5
Habe grade mal Cache geleert:
Jetzt sind 2 BB-Codes da allerding nicht nebeneinander sondern untereinander
Kann man das so machen das die anderen beiden auch noch angezeigt werden und das die nebeneinander sind?
Übrings habe ich grade gesehen das mein Textfeld ein bisschen zu lang ist!


Angehängte Dateien Thumbnail(s)
   
#6
Du musst die Breite des Textfeldes anpassen, damit alle Icons hinpassen.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
#7
Bei hat alles geklappt mit dem eigenen MyCode. Auch die Buttons funktionieren....leider zeigen Sie aber die falsche *.gif.
   
Ganz rechts sieht man zwei B. Wie weise ich denen die richtigen Gifs zu? (Sie sind bereits hochgeladen).
VG,
Susanne
#8
Stimmen die CSS-Klassen wirklich überein? Was hast du geändert?
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
#9
Mist. Ich hatte da tatsächlich einen kleinen Fehler. Aber jetzt ist es noch schlimmer. Jetzt wird gar keine Grafik mehr angezeigt. Nur noch Platzhalter.

Ich habe eingesetzt
Code:
.messageEditor .toolbar_button .toolbar_sprite_isbn {
    background-position: -345px 0;
}
.messageEditor .toolbar_button .toolbar_sprite_spoiler {
    background-position: -368px 0;
}
VG,
Susanne
#10
Du musst so etwas reinmachen, wie background: url(*URL*). Eine Position hilft nichts ohne Grafik. Toungue Normalerweise brauchst du aber auch keine Position.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.