Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
[G] [xmlhttp.php] Invalid arguments passed - wer kennt das?
#1
Question 
Hallo,

ich habe in meiner error.log folgendes gefunden:

Zitat:<error>
<dateline>1220365626</dateline>
<script>xmlhttp.php</script>
<line>690</line>
<type>2</type>
<friendly_type>Warning</friendly_type>
<message>implode() [<a href='function.implode'>function.implode</a>]: Invalid arguments passed</message>
</error>

In der betreffenden Datei find ich an der Stelle nur:

PHP-Code:
$online implode(""$online); 

Leider etwas nichtssagend... Hatte da die Variable $online einen ungültigen Wert?

Tolles AJAX...
#2
Die Variable $online dürfe einfach nur leer gewesen sein, wodurch dir Funktion implode() einen Fehler zurückgibt. Das beeinträchtigt die Funktionalität des Forums nicht, ich werde es aber weitergeben.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#3
Hallo,

wie kann die denn leer sein, irgendjemand (und wenn es ein gast ist) muss doch online sein. oder wann wird die datei eigentlich aufgerufen?
#4
Der Code betrifft die Anzeige deiner Buddyliste im Benutzer-CP. Ist beispielsweise keiner deiner Freunde online, wäre $online leer.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#5
Danke, konnte es "erfolgreich" reproduzieren. Es tritt auf, wenn man eine PM schreiben will und den Link Wähle aus deinen Freunden anklickt (und in diesen Moment keiner online ist).

Sollte vielleicht ins Bugforum. Wink