Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Falsche Weiterleitung...
#1
Hallo MyBBoard Team.
Erstmal alles gute zum Einjährigen Smile

Zu meinem Problem:
Wenn sich mein Co-Admin in das Admin-CP einloggen will kommt er immer auf die Seite "http://forum/......." also ohne das die eigentliche URL davor steht.
Das selbe passiert auch wenn ich ein Forum mit einem Passwort schütze, nachdem ich das Passwort eingebe lande ich auf "http://forum/...."

Und nochwas:
Wenn ich im Admin-CP auf Admin-Berechtigungen klicke, kommt da folgende Fehlermeldung:
PHP-Code:
mySQL error1054
Unknown column 
'u.uid' in 'on clause'
QuerySELECT u.uidu.usernameu.lastactiveg.cancpa.permsset FROM mybb_users umybb_usergroups g LEFT JOIN mybb_adminoptions a ON (a.uid=u.uidWHERE u.usergroup=g.gid AND g.cancp='yes' ORDER BY u.username ASC 

Woran liegt das?

Ich bedanke mich im vorraus für eure Antwort.
#2
Die Fehlermeldung hat erstmal zu sagen, das die Spalte nicht vorhanden ist. Stimmt den die Datenbank bzw. hast du da was verändert?
#3
PHP-Code:
SELECT u.uidu.usernameu.lastactiveg.cancpa.permsset FROM mybb_users umybb_usergroups g LEFT JOIN mybb_adminoptions a ON (a.uid=u.uidWHERE u.usergroup=g.gid AND g.cancp='yes' ORDER BY u.username ASC 
So müsste es aussehen:
PHP-Code:
SELECT u.uidu.usernameu.lastactiveg.cancpa.permsset FROM (mybb_users umybb_usergroups gLEFT JOIN mybb_adminoptions a ON (a.uid=u.uidWHERE u.usergroup=g.gid AND g.cancp='yes' ORDER BY u.username ASC 
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
#4
@Scorpio: Verändert habe ich nichts, habe das Forum erst seit gestern laufen.

@Dragon: Wo muss ich das verändern?
#5
Kai schrieb:@Scorpio: Verändert habe ich nichts, habe das Forum erst seit gestern laufen.

@Dragon: Wo muss ich das verändern?

Welche MyBB Version verwendest du denn?
Ich gebe keinen Support per Messenger oder PN!
#6
Ich benutze die Vesion 1.03.
#7
Hallo und willkommen,

stimmt die URL des Forums in den Einstellungen im Admin-CP (General Configuration)?

Fix zum 2. Problem:

Öffne die Datei admin/adminoptions.php und suche nach:
PHP-Code:
$query $db->query("SELECT u.uid, u.username, u.lastactive, g.cancp, a.permsset FROM ".TABLE_PREFIX."users u, ".TABLE_PREFIX."usergroups g LEFT JOIN ".TABLE_PREFIX."adminoptions a ON (a.uid=u.uid) WHERE u.usergroup=g.gid AND g.cancp='yes' ORDER BY u.username ASC"); 
Ersetzen durch:
PHP-Code:
$query $db->query("SELECT u.uid, u.username, u.lastactive, g.cancp, a.permsset FROM (".TABLE_PREFIX."users u, ".TABLE_PREFIX."usergroups g) LEFT JOIN ".TABLE_PREFIX."adminoptions a ON (a.uid=u.uid) WHERE u.usergroup=g.gid AND g.cancp='yes' ORDER BY u.username ASC"); 

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#8
Michael schrieb:stimmt die URL des Forums in den Einstellungen im Admin-CP (General Configuration)?
Hat nicht gestimmt und klappt nun. Danke!


Zum anderen Problem, da erscheint nach der änderung:
PHP-Code:
Parse errorsyntax errorunexpected T_STRING in /srv/www/httpd/phost/b/de/pytalhost/XXXXXXX/web/forum/admin/adminoptions.php on line 146 
#9
Da hast du anscheinend einen Fehler beim Einfügen gemacht, der Fix ist korrekt. Solltest du sonst nichts in der Datei geändert haben, kannst du auch die angefügt verwenden.


Angehängte Dateien
.php   adminoptions.php (Größe: 8,2 KB / Downloads: 2)

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#10
Klasse jetzt klappt alles!!! Vielen Dank Smile