Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
(1.4) Neue Unterseite im UCP
#1
Smile 
Hallo , ich möchte gerne mit einem hook im UCP eine Unterseite erstellen.
Ich habe es schonmal mit usercp_start versucht jedoch bekomme ich da nur eine weiße seite , sowie auch mit dem hook usercp_end.
(Ich nutze MyBB 1.4 Beta 4)

Kann mir da vielleich jemand helfen? Sad
Zitieren
#2
Wie sieht dein Code aus?
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#3
PHP-Code:
if($mybb->input['action'] == "editdesign")
{
$user $_COOKIE['mybbuser'];
$userid explode("_"$user2);
                  
$query 

$db->simple_select("users","profilebordercolor,profilebordertyp,profilebordersize,profilebg,theadbg,theadcolor,trow1b

g,trow1color,trow2bg,trow2color,tborderbg,tborderborder"
"uid= ".$userid[0]."", array('order_by' => 'uid'

'order_dir' => 'DESC''limit' =>'1'));
            
$editdesign $db->fetch_array($query);
            
$profilebordercolor $editdesign['profilebordercolor'];
                         
$profilebordertyp $editdesign['profilebordertyp'];
                         
$profilebordersize $editdesign['profilebordersize'];
                         
$profilebg $editdesign['profilebg'];
                         
$theadbg $editdesign['theadbg'];
                         
$theadcolor $editdesign['theadcolor'];
                         
$trow1bg $editdesign['trow1bg'];
                         
$trow2bg $editdesign['trow2bg'];
                         
$trow1color $editdesign['trow1color'];
                         
$trow2color $editdesign['trow2color'];
                         
$tborderbg $editdesign['tborderbg'];
                         
$tborderborder $editdesign['tborderborder'];
    eval(
"\$editdesign = \"".$templates->get("usercp_editdesign")."\";");

    
output_page($editdesign);


Ist auch erst mein erster Mod Blush
Zitieren
#4
Ist das der gesamte Code. Wo hast du ihn eingefügt?
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#5
Ich habe den fehler ,
PHP-Code:
global $mybb,$lang,$templates,$invcopy,$db
fehlte.
Nur jetzt wird das header Template usw. nich geladen...

//Edit: Geht jetzt ,hab dann auch noch folgenden code hinzugefügt!
PHP-Code:
global $headerinclude,$header,$usercpnav,$theme,$footer
Zitieren
#6
Wie sieht das Template $editdesign aus?
Zitieren
#7
Dann würde ich noch $header, $footer und $headerinclude hinzufügen. Wink
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren